No sound after Alpha 2 install on Dell E520

I’ve installed Haiku R1 Alpha 2 on a Dell Dimension E520 (3GB RAM, nVidia GeForce 7300 LS).
In general it works well and, because of the great WebPositive browser, Haiku feels to me for the first time like something I could use on a day-to-day basis.
However, I have no sound. The sound card is Intel 82801H (ICH8) which should work with the native HDA driver.
I’ve followed along with the recommendations here ( and certainly the HDA driver seems to be loaded but still no sound.
I’ve even tried OSS and appropriately disabled the HDA driver but still…silence.
Note that I’ve never installed any version of Haiku on this machine before so I can’t say if sound functioned with earlier versions
Any advice?

I’m having a similar problem with a Toshiba Tecra A8. This problem existed also on the old Ubuntu’s up to 7.10. Dough then I did get sound out of the headphone jack. I didn’t check that in Haiku. Maybe you should test that.

Have you tried to use a nightly build?

Yes, you can try nightly to see if that works.

I think the bug still exists.

You should add to this ticket:

Install clean Haiku (without OSS). Upload your syslog to that bug (I think similar to yours). Having OSS installed will change the information in your syslog. Need HDA driver to try finding your audio card and give error info which is not possible when OSS installed & HDA disabled/removed.

That bug is missing a hda syslog (oss syslog is not helpful). Add a comment too to notify developer. If bug is not fixed in 2 to 3 months, look at using another sound card (pci sound blaster live - most of these are supported).

Thank you for the replies.
Well, I installed images from each of haiku-nightly-r38734-x86gcc4hybrid-anyboot and haiku-nightly-r38787-x86gcc2-anyboot successively in a new partition on my Dell E520.
In neither case was audio available.
I also have an old {actually all my computers are old :)} EeePC 901 which has an Intel N10/ICH7 integrated audio card. I installed Haiku R1 Alpha 2 on this machine and this time the HDA driver worked perfectly.
So looks like this driver may have issues with the ICH8 family of audio devices.
I’ll post my syslog to the developer as suggested.

Still trying to get sound in Haiku R1A2 on my Dell E520 but can report just a little progress.
It seems that oss (with the hda driver disabled) does actually provide sound but only on ONE of the sixteen audio engines.
I found this out by trying the osstest module when although all audio engines tested OK, only the following gave sounds (Left, Right and Stereo):

/dev/oss/oss_hdaudio0/pcm0 (audio engine 0): HD Audio play front

  • Performing audio playback test…
    left OK right OK stereo OK measured srate 47983.00 Hz (-0.04%)

However, I’m unable to find how to configure Haiku to exploit this discovery.
Perhaps somebody can point me to a guide.

Edit: I’ve got sound now just by disabling the auich driver. However, I would still like to see a guide which allows me to optimize sounds using the OSS system

Edit: I’ve got sound now just by disabling the auich driver. However, I would still like to see a guide which allows me to optimize sounds using the OSS system


I wonder if that caused issue with hda also. Try installing fresh Haiku and disable all other audio drivers to see what happens with hda.

I clean installed R1A2 on a 3GB partition on the same machine (Dell E520 with Intel 82801H -ICH8 sound card).
In the directory
I then disabled all audio drivers other than hda (namely auich, auvia, echo3g and emuxki).
However, still no sound when I tried the media player. <:-(

Must be an OSS issue then. Kinda weird how auich interfered with OSS driver.

Anyways, best bet to fix is with a ticket and I saw you added to one already. The developer will try to get it working for you if they can.

Surprised you find the auich interference thing weird as I got the idea to try disabling it from a posting of yours of a few months ago.

Weird because auich should not interfere with OSS driver.

Unless you have audio hardware that is recognized by auich driver too. ie: OSS is general audio driver to support many sound cards. So, it can conflict with specific audio drivers written for Haiku but this should happen only if you have hardware that uses a specific audio driver.

That is why we say to disable hda when using OSS on a motherboard with high definition audio chip.

Delete the haiku audio drivers located at /boot/system/add-ons/kernel/drivers/bin. Then install the oss drivers. After that restart your computer. Then go to media preferences and change the default output channel to channel 6, then restart the media server. Then enjoy the good music.