No network as qemu guest

Creating a Haiku guest VM in Virt Manager.

  • tried E1000, Virtio and rtl8139
  • did a complete re-install with each adapter change

The network panel reports the name of the device correctly (e.g., Virtio) but cannot reach internet or ping LAN.

I notice in the network panel, IP4 shows DHCP selected but no IP address.

FWIW, I have internet on the host, and I have other VMs that run ok.

Any suggestions?

Bottom of this page could be of some interest…

Thanks @Starcrasher, I did examine that page but the “User Mode” setting is absent in Virt Manager.

I have generally good experiences with Qemu (edit: without VirtManager) And maybe it’s important which host OS.


@PeterW maybe so. Since I can spin up Linux guests on this system with the same settings makes me look at Haiku though.

Is there any network config I’m overlooking in Haiku? I can see the adapter in Haiku – for example, it says ‘virtio’ in Haiku and even says ‘connected’ – but I don’t seem to have an IP in Haiku.

I also have a similar issue — the network comes on and off, displaying the connection status notification permanently refreshing.

If nobody else has a clever solution (network experts?), I think it is a Haiku bug (both @phalange and @bitigchi).


@PeterW thanks for your responses, bug report submitted.17868

Hmmm. Got the same problem. In fact, it is caused by firewalls. I had to tweak things a bit and now it is working. For example, on a Mageia, with Shorewall I had to do this