No development tools by default on x86_64 nightly

I did a fresh install with a current x86_64 nightly a few days ago (can find out the exact hrev if needed) and discovered that by default there is no gcc and no make (and no binutils etc…). Is this wanted or is this a bug in the installer? If it’s a bug I will create a ticket of course.

For me it’s no problem, I just installed the needed packages with pkgman.

"These “nightly images” are provided mainly for development and testing purposes.
While we do try to keep our code in a working state at all times, these are not considered to be stable and may be broken in various ways at any given point in time.

To keep the file size down, nightly images lack some extra bundled software included in regular releases. You can install these and many more packages with the HaikuDepot application."

I agree that it seems odd that it would be missing those sort of utilities, but IDK if there’s a list of what is/isn’t supposed to be included. If packages are complete bundles that don’t require development tools, maybe you can grab those with HaikuDepot?

I regularly install nightly versions of Haiku and use them for app development. So far the dev tools were always included.

Hmm. That does seem a little suspect. Maybe they decided it didn’t need to be included? It’s probably not the tiniest thing. You could try doing a checksum on the disc image file if you still have it and make sure it matches OR do a full reinstall, unless you it would be a significant issue, and check if you have to manually re-add it again?

You can try specifically mentioning one of the developers in a comment. I’m not sure, but I think that’ll make it show up in their notifications unless they have that forum setting turned off. Or you know treat it as a bug.

Did you run the Installer or just run your downloaded image?

We made some changes (before the beta2 release) to reduce the memory needed for the “live” mode when booting from CD and to help running Installer on low memory systems. The main thing is that some packages are present on the nightly image but not enabled by default (they are in a separate directory named _packages_). Installer allows you to install these, or not, when you run it, if you did nothing special, the final install should have them all enabled.

1 Like

I made a normal install using the installer. At the optional packages setting I left everything at the default.
But I`m starting to suspect that there´s something else wrong with my install. When I wanted to install gcc via pkgman I got the following error:
“*** failed to commit transaction: The to be activated package “binutils-2.31.1-2-x86_64.hpkg” does already exist”
I ran into similar errors when trying to install other software too. Had the same error with the gmp and mpfr packages too.

I still have the iso image around that I used for the install. I’m going to do a fresh install from it in a vm and report back if I run into the same problems.

Was it an install on a freshly formatted disk or did you already have something on the target disk? Updating an install this way does not work well currently.

Related bugs (don’t forget to vote for the most annoying tickets!):

As clean as it gets. Partition newly created and formatted.
The only thing I did that I usually don’t do was booting to the desktop first (to check hardware compatibility) and then run the installer from there.

Thanks for the links to the tickets. The first one doesn’t relate to my problem as I used a freshly created and formatted partition for the install. But the second one definitely fits what I’m seeing on this Haiku install.

We really need to fix those pkgman related issues before the next beta. :confused:

1 Like

Just made the install in the vm, also with booting to desktop first. gcc and other dev related packages are installed by default and working.

Is there anything I can check on that on the installation with the problems before I reinstall Haiku on that machine? I’d like to contribute to the bug solving if I can.

I have now reinstalled the machine with the same hrev (albeit using a different usb thumb drive to install) and all optional packages including the developer tools are installed correctly and working so far. Also the problems with pkgman have not occured as of now.
I have no idea what happened on that previous install, maybe the install media was corrupted in some way.
But at least my problem on that specific machine is solved for now :wink: