No bootable device

So I installed Haiku from a dvd and after installing my laptop boots with “No bootable device – insert boot disk and press any key.” How can I fix thsi?

I have the same problem. I tested every possibility from GPT with prepaired partitions (efi and BeFs) to MBR. Nothing worked.
I use a second USB Stick (You can use even your dvd). Directly, when the system starts to boot from dvd, press the space-key. You get a Haiku boot menu and can boot your hdd from there.
It is not the best but it works. I gave up searching a solution to boot directly into Haiku.

That probably means the bootloder wasn’t installed/is damaged, maybe try the tool writembr from the commandline or tools->write boot sector in the installer.

With using a mbr my laptop didn’t boot Haiko, neither after using writembr. Could be a problem from my laptop but other Linux systems boot with mbr.

I got Haiku now booted with a little manual work. I copied the anyboot loader (Efi folder) to an old usbstick. Then I booted GParted live distro and made a new partition label (GPT) on my hdd in my laptop.
I manually created an 200 MB (it is an usual size, less will do it also) EFI partition. After that I mounted my old stick and the EFI partition in GParted live and copied the anyboot EFI folder on my hdd. This was the most important part.
I booted in my Haiku USB stick that I used till now, started Drive Setup and created a new BeFS partition on the chosen hdd.
With the Haiku installer I installed Haiku now on my hdd.
I rebooted and finally Haiku OS booted on my laptop from hdd. Enough work for today but I’m very happy to reach this target. :smiley:

Nice job! This information could be helpful for other people in this situation. I know we want to improve the Haiku installation experience related to the booting options.

1 Like

Thank you. :slight_smile:

Hmm… :thinking: That’s bad that your PC didn’t boot during the start of this topic :anguished: So there’s an extra action idea:

You can install Windows XP also to use dual-boot between Haiku and Windows XP.

The problem is solved as I wrote before. Booting is now straight and fast.
I would never install Windows XP. It is too old and heavily oudated. I use Windows 10 for gaming. For everything else FreeBSD and sometimes Fedora Linux.

Uh… I hate 10. :angry: I like Windows XP better. :crazy_face: