No boot 54077 64 bit NVMe SSD

photo_2020-04-21_23-24-42 device Mass storage controller (Non-Volatile memory controller, NVM Ex [1|8|2]

vendor 15b7: Sandisk Corp device 5002: WD Black 2018/PC SN720 NVMe SSD

rev 54010 work fine !

NVMe driver is not complete and contains serious problems. You should stop using it until it will be fixed. hrev54010 is not fine, it cause file system corruptions and may destroy data.

1 Like

I installed Haiku on a NVMe drive in May 2019. Prior to revision 54016, there were no particular problems. In this revision, the writing to the disk is broken. In revision 54077 no boot.screenshot168

You was just lucky that you didn’t have no particular problems or even you may be not aware of already occurring problems. See #15123. You need to wait until NVMe driver will be fixed. You can continue using old version at your risk.

1 Like

You may have BIOS settings for switching SSD to SATA mode.

Yes, the NVMe driver was not particularly well tested at the point it was merged, and now it has become clear that it has serious problems with disk corruption. This is more apparent when doing heavy disk usage e.g. compile jobs, and also when there is high memory pressure and physical memory fragmentation.

If you never had disk corruption, then I guess you were just lucky one way or another. At least @Diver has seen them in VMware for a while, and I finally managed to reproduce them in QEMU. @KapiX has reported them on real hardware.

The good news is that I finally understand the bug and so I should be able to write a fix, and also that I ordered a new machine with a NVMe drive as its primary disk, so I should be “dog-fooding” the NVMe driver pretty shortly.

Sorry for the disruption, but, well, that’s how volunteer OS development with no dedicated testing team goes…


I am lucky! The operating system worked stably on a NVMe drive for such a long time. I regularly updated revisions of night builds.
I had no reason to issue tickets in the bugtracker.

The operating system runs continuously for over 9 hours. WD Black SN750


1 Like

Quick update: I’ve managed to get an alternative version of the NVMe I/O path partially working in my local branch (larger I/O fails at random.) Unfortunately, however, the features I’m using (hardware SGL) are not supported by first-generation NVMe controllers, and not by many emulated ones either, so I may wind up having to implement a “slow path.”


Rev 54081 - not boot NVMe SSDphoto_2020-04-24_20-02-21

I’ve now finally fixed the NVMe driver (and some kernel bugs that the fixes exposed, to boot!) in hrev54102. Not only that, the driver should now use a bunch less CPU than before!

Please be cautious when using it, but overall, I haven’t seen any issues, and the ones I could reproduce are now definitively gone.

Sorry for the wait, and sorry for not testing the driver more in the first place.


Release early release often, you may never have realized any of this had you not pushed forward with it as fast as you did. Most people knew the risks. and now you have something the be proud of.


Rev 54105 NVMe SSD - work fine!


Rev 54121 - work fine!!!


Great job!
Copying large files now error free.


If this was a problem before, why did you not report it? I only learned of it because KapiX reported errors; if you had reported it with a syslog earlier, I probably could have fixed it sooner, too.