News about UEFI


There are some news about UEFI ?
I believe you thought to integrate it in the Beta , we will no longer have to be far .
I’m an optimist …:grinning:

Still no official build available, but you can get the old and unofficial Uefi build from jessicah and update it just normally, or you can build it for yourself.
It would be great to have offiicial image btw.

1 Like

where it is?

I suppose this one:

Write with dd on to an USB drive and boot from it with UEFI enabled, secure-boot disabled, usb3 disabled.
It is an 64 bit Haiku, so it works only on 64 bit computers.

No idea about UEFI-32 on x86_64 hovewer (like early Intel Apple Macs). I suppose they won’t work.

OK , thank you for link

I’ve tried this iso , but i’ve got same bug , " did not find any boot partition" .

I have tried with uefi mode or legacy mode, the boot disabled, I have no USB3.
It is not dramatic, it is a PC that I recover, I will wait.
I have a version Haiku on another PC.
if it interests someone, I can take the hexa codes of kernel panic.

Thanks for the feedback.
As it is an only-uefi boot image it won’t boot in legacy mode as it expects uefi support.

Why your boot partition not found: i don’t know.
The kernel panic won’t say much, but a complete hardware report (lspci?) could help to debug this.

In the meantime you can try to use another USB port…

Good news , i’ve got a solution , i’ve keep on the “shift key” on boot and this work…(install only in english).
I don’t think it’s right way .
But i’ve got a PB with uptdate , i can’t use nightly update , i’m freeze on rev51157 .
May be it’s normal (efi version) .
i’ve try change repositorie , no work.
Currently i use ubuntu boot loader , is it possible update with nightly ?

I tried to boot it on a MacBook Air and I got the same error. I tried the USB on a Gateway TB120 (BIOS) and it worked. I also tried the last nightly build on the MacBook Air but it didn’t recognized the USB. What does it mean that the UEFI branch was merged? How do you enable it in the nightly builds?

It is merged, but not included in the nightly builds. The reason is that we can either make a BIOS-compatible, or an UEFI-compatible image, but not both in the same image. Some extra work will be needed for that.

So if you want an UEFI image, you can use one of the unofficial ones (I don’t have a link at hand), or build one yourself. Don’t worry, once installed, you can update it in the normal way, so it is not a problem to start with an old-ish image.

1 Like

No idea about UEFI-32 on x86_64 hovewer (like early Intel Apple Macs). I suppose they won’t work.

Yes, I asked about this some time ago as I have an older (32 bit) atom laptop and a macbook core duo both with with UEFI, but there are no current plans to support it (no idea how much work is involved).

UEFI is sensitive to the type of partition table - under Linux there are two different types - the old MBR and the new (is it GPT or something - I don’t use it) - anyway it’s necessary to use the right one with different combinations of UEFI, secure boot and legacy boot. I assume that Haiku would mimic one or the other. There are some laptops that have UEFI but won’t boot EFI images. My ACER is an example. In this case it’s very important to have an MBR partition table and legacy boot, and it also requires a Fat32 type partition.

1 Like