New to Haiku, problems with instalation

Hi guys, it’s my first message to this forum :slight_smile:

I have a problem, so I’m here.

I’ve made an old PC just for fun (and old games), and I wanted to try Haiku on it, but it won’t boot. The PC is:
Abit BP6 motherboard, 2 Celerons at 550MHz, 512MB SD RAM, GForce 2 64MB, Voodoo 2 SLI, Creative AWE 64 Gold ISA Sound Card and a Maxtor 40GB HDD. Currently the HDD is hooked to the HPT366 UltraATA controler on the mobo, instead of the integrated ATA33 controler, and it’s running Win2K decently (I’ve added HPT366 driver during instalation via floppy drive).

I tried booting the LiveCD of Haiku, it starts booting and after the 4th icon colors (flashes up), the boot stops, console pops-up and I get a message that there are no boot partitions detected. I’ve tried diconnecting the HDD form HPT366, changed the DVD-ROM from slave to master, and tried changing the boot options, but nothing changes.

Where do I go from here? I’m a total beginer at this, haven’t gone far form Windows so far, but I want to expand my (limited) knowledge. And so I need your help…

Just to add, I’ve added an old 6.5GB HDD on the integrated ATA33 controler (motherboard is with Intel’s i440BX chipset) just to try if it’ll work, but the problem remains the same - no boot partitions detected!

Is there a way to install Haiku as the only OS on a PC?

This looks like your issue:

Search tickets here for any other similar:

Looks like a CD-ROM issue I believe. HPT controller may or may not work. Try with integrated ATA33 controller to start with.

Hold SHIFT ( or keep pressing SPACEBAR ) when booting Haiku to enter into safe-mode options.

Since you have an extra 6 GB drive to play with; dd Haiku to it. You will only get access to about 700 MB. No worries, use Gparted to resize partition on 40 GB drive if you want to keep Windows, boot 6 GB drive, drivesetup ( don’t initialize as haiku; use slightly different name; ie: haiku-os ), run installer, install to partition on 40 GB drive.

Use CD (or 6GB Haiku), boot into safe-mode, tell OS to boot Haiku off 40 GB drive. From terminal, type bootman to install boot manager.

dd haiku to usb key (same idea for drive partition but you should dd to entire 6 GB drive to avoid having to install any boot loader; ie: bootman, Grub, etc.)

tonestone57’s probably right, but I just want to add a problem I have had with Haiku. When I boot Haiku on my laptop with the external mouse plugged in, Haiku only goes up to the fourth icon (like you said for your problem). I remedy this by force turning off my machine (by pressing the power button for about five seconds), unplugging my mouse, and then turning it on again without the mouse plugged in, and then I plug it in after Haiku finishes booting.

Hope it works well for you.

OK, so I made an advance, but I’m stuck again :slight_smile:

I’ve installed Haiku to the 6.5GB HDD, by choosing “Disable IDE DMA” in the safe mode settings.

Now it’s on the HDD, but it won’t boot (again) from the hard drive, if I don’t put the CD with Haiku in the drive and choose “Disable IDE DMA”, and then boot from the hard drive.

I’ve tried looking for the i440bx driver (if that’s the solution), but had luck finding it…

What to do now?

I’m also trying to boot installer on a BP6 based system but it reboots before the haiku screen…

What is your setup? How did you manage to boot, did you use any of the safe mode settings?