New install hangs on "Grub loading"

Hi there!

I was curious in just trying out Haiku as I fondly remember BeOS. I have a brand-new Dell Latitude E7240 to try it on. I wrote the anyboot img to a USB drive and booted with that and used it to install. Seemed straightforward enough. But then when I tried to reboot the laptop, it just sits at “Grub loading” and doesn’t proceed.

I repeated and checked my steps several times and same thing each time. The “live” install on the USB drive runs fine though, so at least I was able to play with that.

I tried both R1A4 as well as the latest nightly. Same thing.

I’ll need to give this laptop to it’s real, final home shortly but figured I’d pass this along. I could hold off a while though if you wanted me to try stuff.


When you install Haiku, it assumes you already have a boot manager and doesn’t overwrite it. In your case, it seems you had Linux installed, but removed it when installing Haiku. So, you’re left with the Grub boot sector, and no Linux partition to load Grub from.

In our Installer “Tools” menu, you can install our own boot manager. This is much simpler than Grub, and it can’t boot Linux. Or you can install a standard bootloader that fits in the MBR such as Smart Boot Manager, or even Microsoft’s MBR that just boots the first active partition.

This is all detailed in the long text before the installer, but no one reads that :frowning: