Networking notworking under vmware (Update: DHCP failing)

Oops! Sorry, my problem is very similar to “Installing new software in VMWare, internet connectivity?” submitted by Matt Stevenson. Anyway, I notice his problem has not been resolved as far as I can see, so here goes.

It’s been a while since I tried any ftp or netpositive sessions using Haiku under Vmware although I’ve been downloading vmware images regularly. So I tried the some time ago and found that I could not connect to any web sites. I went to the terminal and did an ifconfig and everything seemed in order but “ping” results in “error: unknown host:”. I left it alone for a while assuming that this was a temporary situation and that it would soon be fixed.

Now I’ve just tried build 24449 and alas it is still happening. If I use the network preferences applet I can change the IP address to a chosen value in Static mode but if I set the mode to DHCP the OS appears to be using the default value for failed DHCP requests i.e. See

This happens whether I set the Virtual machine network interface to Bridged or NAT. It happens on my laptop whether I’m connected by wire or wireless.

I’ve checked what windows XP does in the same environment and the only time DHCP fails is when I"m using bridged mode for the vm interface and the laptop is connected using wireless.

I’ve also checked this on my desktop using a Windows 2000 host with the latest available version of vmware player and I am getting similar results. My laptop is a Ubuntu 7.10 host running vmware server version 1.0.4 build 56528.

Back when the DHCP had just been implemented, the whole thing just worked!

A suggestion for the programmers, maybe the network preflet could also indicate the current state of the DHCP process i.e. “failed”, “success” or “negotiating”. Currently if I bring up the network preflet while DHCP is attempting to negotiate an address it just gives me a false IP address ( and indicates that it is in static mode. Under the same conditions, ifconfig indicates no IP address.

Update 2008-03-23:

Did a little detective work using the Windows XP vm to find out the IP address of the vmware DHCP server, the netmask, default gateway and DNS server in the vm environment. If you don’t know how, open a command prompt in windows and type “ipconfig /all”. I then copied all the values into the network preflet and hit the apply button. Did a quick “ifconfig” and “route list” and everything seemed OK. Hold my breath, “ping” and viola! “64 bytes from yada, yada, yada”.

Next, since we are now working with a 250MB image instaed of the old 100MB I try “wget http//… the url for the latest firefox on bebits” and wget downloads the 12MB or so of firefox in 1 minute 6 seconds! I then expand the file, browse to the newly created firefox folder and run the firefox script. I get an error message and firefox aborts but, I remember behavior like this from a previous life so, I run the script again. I get a warning message about security settings and something about profiles so I hit OK and now I’m browsing the web using firefox under Haiku!!!

I guess DHCP under vmware is where the problem is.

I have the same problem, but I can’t get it working even after following your instructions. I’m connected through a mobile internet connection. Maybe it only works with lan/wlan?

I, too, am having this issue, whether I try to hack it by manually entering IP address info, I just can’t get it to connect. It’ll resolve if I put my gateway address as the DNS address, but I just can’t get it to connect to the Internets. Any of them!

I’ve been lurking on the Haiku-commits mailing list looking for commits that might fix either sound under vmware or the problem on this thread. Yesterday I noticed a post that looked like a likely candidate:

I download a new build of haiku every 100 builds or so and since I was due to download again, I downloaded last nights build (26003). I ran it this morning and, you guessed it, DHCP is now working again! Thanks Jan Kl and Axel!

On another note does anybody else think that the haiku.vmx should set the vmware interface to NAT mode by default, instead of Bridged mode.I noticed that the two previous posters did not explicitly state whether they were using the vmware interface in bridged mode or NAT mode. On my laptop running ubuntu, with s small hack to get the wireless working, the vmware bridged mode interface does not work. I can think of a couple of logical reasons why bridged would not work, even when on a wired lan. On the other hand NAT mode always seems to work, regardless of what type of network you’re connected to.


P.S. For the last few months I have done all my Haiku related browsing (bebits,haiku-os,ico,haikuware), incuding the posts to this forum, using firefox on Haiku under vmware. It takes less than a minute to start vmaware, launch Haiku and start firefox! I monitor the mailing list and check for nightly builds from firefox on ubuntu.

I have this same problem (in rev 28446 and two builds before), but with one important difference. If i start the networking preflet i can’t fill out any field (like DHCP in the modes menu) because there isn’t even an adapter. Haiku doesn’t see any devices.

I tried editing the .vmx file to fix the following lines:

ethernet0.present = "TRUE"
ethernet0.connectionType = "nat"
ethernet0.startConnected = "TRUE"
ethernet0.virtualDev = "e1000"
ethernet0.wakeOnPcktRcv = "FALSE"
ethernet0.linkStatePropagation.enable = “TRUE”

but it doesn’t help at all and vmware is actually changing it to this:

ethernet0.virtualDev = “vlance”

so now what could i do? I’m an amateur with zero experience in BeOS and uptill now i have only used vmware for supported OSs… :stuck_out_tongue:

Haiku is very pretty, even as a pre-alpha. If i could only get internet to work it would be a very very nice platform to try out my software.

Haiku doesn’t currently come with a “vlance” driver, so unless you can convince your version of VMWare that e1000 is a perfectly valid ethernet device, it sounds like you’ve got a problem :slight_smile:

I haven’t tested Haiku with vmware in many months, but last I heard, the vmx file that is provided on does work with VMWare still.

Edit: Make sure you’re editing the vmx file while vmware is NOT running, vmware has a habit of overwriting the file when it shuts down, and any changes you made while it was running will be lost.

I totally overlooked the vmx file on the download page. It’s working now, thanks alot!