Network woes: am I doing something wrong, or should I file a bug

Howdy. I’m working on getting Haiku up and running, having successfully figured out rEFInd. Unfortunately, I’m having issues that make it tough to use.

I’m using a Lenovo Thinkpad X380 Yoga. It works well, for the most part, but network access is extremely slow using Ethernet, and both the wifi cards I’ve tried, an Intel 7265 and 8265, don’t work.

Speed testing shows a few megabits down and maybe 50kbps up on a cable connection that’s supposed to be 400mbps down and 10mbps up.

The built-in NIC is an Intel I219-LM. I saw an entry in the unofficial hardware database saying the 7265 was working, but according to the syslog, it tries to load the firmware and fails. (I ran to no avail; incidentally, this currently has trouble downloading a couple of firmwares for cards I don’t have.)

Does anyone know of any workarounds for this pair of problems? I work at an e-waste recycler and am gonna grab a 7260 and a handful of other cards at work for further testing, but my recollection was that the 7260 was deeply flawed in terms of receive reception. I’ve also got an Intel AX210 in the mail but it’s not here yet.

This problem could happen at any layer of the stack, really. But I would first check to see what happens under another OS with the exact same setup (hardware, cable, etc.)

This isn’t needed for that driver at all.

What error, precisely? And, what version of Haiku are you running?

This might be the same as #17833 or #17966. There is some sort of problem with this driver on Haiku that sometimes prevents firmware from loading, it seems (it works fine on my hardware, I’ve yet to reproduce it.)

File a ticket :slight_smile:

1 Like

Ethernet works at full speed on Windows. I can do further diagnostics later today. It does seem to be the same problem as 17833; iirc the syslog entry mentioned the same chunk.