Mouse pointer and/or desktop frozen during startup


almost every time the first startup ends with a frozen system, sometimes with a complete desktop but frozen mousepointer, this little icon like a hand with stretched forefinger, sometimes with incompleted desktop and parts of dialogboxes without descriptions and so on (and frozen mousepointer, too).
The second startup after rebooting is more often than not successful even though rebooting is a little bit difficult from time to time.
ALT-CTRL-DEL may work but often does not work too.

I didn’t try out whether or not the third startup would be like the first or how long the delay has to be to produce this behaviour.
It seems that nervous handling with the mouse during booting causes this problem very sure but even if I don’t look at this nice mouse it may happen.

Just yesterday I changed an item in bios that controls the behaviour of input pointer, that means touchpad and/or mouse.
I changed from “Auto” to “Both” and Haiku did not boot! Not even the boot logo, these 5 or 6 pictures lighted up with the progress of booting did appear.
(I hope you understand my confused and helpless explanations)

Finally a short description:
HP Omnibook 6000, Pentium III, 850MHz, 384MB RAM, PS/2-Mouse, ATI Rage 128 or something like this,
20MB Harddisk, Ubuntu 10.10, Haiku and GRUB

Best regards

Sounds like a graphics card driver issue. The Rage 128 driver isnt working in Haiku from what I have tried. So you should hold down the space bar during booting and choose “safe mode” and video card settings. I suggest 800X600 and 16 bit. If that dos not fix frozen desktop, switch to USB mouse which works perfectly.

yes, good advice from previous poster.

Could be video card driver affecting the boot. Use VESA mode. Boot into safe mode by pressing SPACEBAR or holding down SHIFT key.

Enable failsafe driver + 800x600x32 video mode.

Could also be PS2 issue. Disable trackpad/PS2 in BIOS if you can and try booting with USB mouse.

Going into safe mode while booting is best because you can disable other things like ACPI, DMA, SMP, … which could also be affecting you.

Thank you for these helpful advices!

The problem seems to be solved, I hope.

After the first installation of R1A2 some month ago and this well-known problem of WebPositive and its missing libs I tried out later some nightly-builds, but because of my unsufficent knowledge about Haiku structure and system these changes on nightly-builds have not been very useful.
(desktop icons with broken links because the target was not there and so on, I am not as familiar with Haiku as with Debian e.g.)
And instead of annoying the whole community with always new problems I decided to install once more.
Fortunately I had lost my original copy of R1A2 and had to download a new one.
This new ISO ran without any problem and installed a fresh system without the need to purge the old version!
Some parts seem to be overwritten and others has survived the process.
This actual downloadable copy of R1A2 seems to be corrected in matters of above mentioned problems and in addition I have no longer a problem with frozen desktop and/or mousepointer!
Till now!

Nevertheless I would be glad if anyone would give a short explaination about the advantage of nighly-builds and of course the disadvantage or limits, too.

Best regards

nightly builds have the latest code and changes which may fix certain hardware issues or update programs or drivers and include new stuff/code but they may have extra bugs or in some cases be unstable to use. If unstable or buggy, you can always install an older or newer version to fix this situation by downloading another nightly.

R1A2 had a couple of issues that were fixed in nightly builds.

When installing nightly build, the system folder is wiped out (replaces it with newer version) and merges all the other files, ie: replaces libraries in common folder with newer ones while keeping all user files. So, you get the newest OS and files without losing any user files.

You should follow haiku development here:

And avoid nightly builds that have major changes happening to them for 2 or 3 weeks or any where you see lots of new bug reports appearing after changes.

ok, I think I do understand a little part of nightly-build procedure…
Based on my newly installed R1A2 without almost any changes except format of time at first I installed a nightly-build from 01.November (and today an update-to-date nightly-build).
Without regarding any may be well-known issues.
The result in both cases is:

The desktop icons of Welcome, BeBook and User Guide have another appearance and they are not working (“There was an error resolving the link”).
In particular the User Guide is very useful for as a beginner.

After installing the 01.November-nightly-build I got or kept a non-working webpositive with very strange behaviour:
no action because of missing libs,
no re-installing because of it is already installed,
deleting as suggested didn´t work because there is nothing installed…

After updating today with nightly-build from today re-installing by “installoptionalpackage -a webpositive” has been successful without any error.

How do I get the User Guide or a correct linkage ?

Best regards

You’ll get the user guide and welcome page with installoptionalpackage Welcome.
Like Web+ it’s not included in the Knightleys to save space.


Thank you for this advice,
unfortunately I am far from home the next time… no wired network but only UMTS which I am using right now with Ubuntu.
Is there any intention or even application for support these kind of mobile networking?