Mouse does not work on BeOS installed in Virtualbox

It took me a long time to install BeOS on VirtualBox, and the same during the installation works for a few seconds, but then the mouse stops, and goes to the extreme northwest corner of the monitor.

What are your settings under System and Display?

1 Like

I had the same problem. I found no solution for it. Put it on my laptop on a second drive. That worked reliably.

1 Like

On the computer, or on the virtual machine?

On the computer. In VirtualBox always mouse problems. Seems to be some code in Haiku fights against VirtualBox somewhere.

1 Like

I think this thread is about BeOS not Haiku.

1 Like

http://web.ncf.ca/au829/WeekendReports/20130309.html


There are still a few bugs that may cause problems. One is that the mouse sometimes locks up and gets stuck in the top left corner. Restart the media server to fix it.

1 Like

Sorry, in the virtual machine. I have BeOS running in a VM. I can compare settings with you.

1 Like

how to open the terminal on the BeOS installation screen?

Try Ctrl+Shift+t.

1 Like

No, this shortcut does not work

Is there any other way to access the terminal on the installation screen?

Maybe with Cmd-Opt-t (Win-Alt-t), not sure if it works in BeOS.

1 Like

Can you complete the installation using Tab key to activate needed buttons?

1 Like

no, I can even select the options, but the enter key doesn’t select the option I’m on

In Virtual Box, default Right Ctrl key breaks the mouse capture, using the Virtual Box menu, insert a Ctrl Alt Delete sequence which should bring up the Team Monitor, then using Tab key to navigate to input server, select with spacebar, navigate with Tab key to Kill button, select with spacebar, cursor (along with input server will be restarted).

Try spacebar instead of enter.

1 Like

It worked!
I was able to finish the installation

1 Like

I managed to kill the media server process with this method, but every time I log out and enter BeOS, I have to repeat this and kill the process again

This shortcut didn’t work either, but as I already managed to install BeOS, so everything is fine
thank you anyway!