Mounting Images


I’ve been trying to mount filesystem images so that I can easily transfer files to my virtual pc in qemu, but can’t get the command to work. I typed

mount file.bin  /folder
I've tried this with images of an entire disk, and a dd of one of my partitions, but all I get is
mount: Invalid Argument

Can anyone help please?!?!?!?

Is it a raw disk image? If so, you should be able to just double-click it and it’ll get mounted. I always do this when i need to update my Haiku installation to a newer revision.

Sorry, my post didn’t get through for some reason. yes, it is a raw image. I’ve just tried the double click thing, and get an Invalid Argument error. By the way, what do you do when you update your version? I have always found it annoying having to download over 100MB just for an update.

Sorry to hear that. I’m not sure what could be causing the issue. What Haiku version are you using? If you’re on Alpha 1, could you try on one of the more recent nightly builds? Also, maybe there are some special features being applied to the image, or it’s a different disk image format. I remember using Qemu at least, and there you’re sometimes adviced not to use a “dynamically expanding” (Not a set file size, it grows as the image is filled by your virtual OS, in contrast to an image which always keeps the same static size) hdd image, if my memory serves right. You could check if your issue has something to do with this.

I have a very minimal install on a partition with the size of a few hundred MBs, which I use when I need to fix something or install Haiku. Then I have my regular Haiku installation on a bigger partition. When I feel like updating to a newer revision, I download the newest raw image I can find on, extract it somewhere, and in the minimal Haiku installation, I mount the image and run the Installer. :slight_smile: Yes, it’s over 100 MB. I have a fast connection so I didn’t find it to be much of an issue, though I can see how it could be annoying for some.

Thanks, I’ll try that. I’m going to install a nightly, but I just got a new HDD and had all sorts of problems with it. Once I’ve finished upgrading my hardware, etc. I’ll install the nightly, and see what happens.

Just found this again. I know it’s really old, but I still don’t know how to do it! I have a floppy image that I need to edit, and can’t get it to mount using the methods above. I’ve tried changing the filetype to ‘Volume’.

It just sort of worked. Still said 'Invalid Argument’when I double click it, then appeared on the mount list on the deskbar, then went, then appeared in disks and then went, and now nothing seems to be happening, although it’s taking ages for the mount list to appear.

Hi stellarpower!

I haven’t really messed with floppys or floppy images (or that much with images in general), so I just googled and downloaded a bootdisk image. This mounts with “mount CDBOOT.IMG /folder”, though only read-only. “mountvolume CDBOOT.IMG” does it writable. It even mounts writable on doubleclick after setting the filetype BFS Image (application/x-bfs-image).

Maybe your image is corrupted? Or the filesystem is not supported?


Just to make sure, does /folder exist prior to running the mount command?

Thanks, I downloaded an old windows setup disk. the

mount CDBOOT1.IMG /folder
command still says
The mount point /folder’is not accessible.
I didn’t know the mountvolume command, but that worked alright. Also, I’d been setting the filetypes to ‘application/x-vnd.Be-volume’, not bfs image, so now the floppy images mount aswell. Thank you Humdinger!

No, I didn’t think one should create folders in the root directory.

I don’t think creating folders in the root dir is discouraged. Doesn’t have to be in the root dir however, as long as the specified folder exists.


When mounting images or partitions through Tracker, the directories will automatically be created in the root. However, when using the mount command, it expects that the mounted path exists already.

Ah! That makes sense now. Thanks, I’ll try that as soon as I can.