Missing glib2

I installed all Glib packages in HaikuDepot (also the x86 version), but when I run ./configure for audacity it bombs out at
_Package rerquirements (glib-2.0 >= 2.32) were not met:

No package ‘glib-2.0’ found_

There are many glib related libraries in /system/lib etc but for some reason ./configure doesnt see them at all.
Very annoying: pkg-lib also returns an empty string. Since this is a very basic library there is something simple I missed but, what do I need to set up my development library?

If you are on gcc2h, first switch to the gcc5 toolchain with:

setarch x86

In Terminal. It makes gcc5 as current compiler temporarily in your terminal session.

Audacity requires wxqt, but wxqt requires Qt, and Qt is only available as secondary arch on gcc2h. So you need this, and needs the _x86 (and x86 devel) packages for every dependecies.

All these dependencies are met. I have installed these files, still Glib2 not found.

@waddlesplash has been working on the Audacity recipe for haikuporter recently.
Even if you do the porting “manually”, maybe it can help you.

Thanks, tried that. Running in to a porter issue. libffi crashes. Libffi should be installed (see the libraries in the FS) but haikuporter cant work with them. Using haikuporter to first port libffi fails with a dependency error “cant compile: libffi depends on itself” and thats where haikuporter stops.

So somehow: this system is completely broken. It can find Glib, it doesnt see libffi, can compile applications because they depend on themselves…

When’s the last time you updated your ports checkout and HaikuPorter? And I’d recommend running the build with “–get-dependencies”, which should solve some of the ffi problems.

Thanks, I installed it this afternoon.

It more or less looks like Haiku chooses to let users build the system themselves, compile everything: otherwise, why would people continue to update recipe’s instead of uploading packages? If this is the direction: the system has to become bullet proof and not crash on dependencies

For now, I decided not to put anymore time in Haiku until it is more stable. When a developer spends more time on his platform than his code, its not the right platform :slight_smile:

We do have packages uploaded. It’s just that the wxWidgets and (WIP) Audacity ports just got added a few days ago, so nobody has had time to upload them. glib2 there are already packages for and have been for some time.

And we’re working on a system which will build packages and upload them automatically, which should improve this situation greatly.


The issue with Glib2 is what started this. The libraries are installed but pkg-config doesn see them, even if I give the library locations to the ./configure… Still, it doesn see them.

I tried compiling mp123 because the standard mediaplayer cant handle VBR HQ mp3. So I installed SDL (everything and the x86 versions). Yet configure didnt find them. OpenAL, not found. Opensound system, not found.

This means that I probably havent correctly set up my compilation environment, it can however also mean that the build system in Haiku is broken. I can only find long documentation about settng up the development environment for compiling Haiku itself, but thats not what I was looking for.

You see: to much frustration for something trivial as findiing the libraries so the compiler can compile code :slight_smile:

Sorry for the naive question, but you did install the _devel packages as well, right?

Its not a naieve question. That was my first error when I learned Gtk. I installled the -developer packages.
I decided to wipe everything and start from 0. This way, I will not waddle through previously installed packages.

Naive question: what is mp123?

I think this one: https://www.mpg123.de/
But afaik we have recipe already for that: https://github.com/haikuports/haikuports/blob/master/media-sound/mpg123/mpg123-1.23.8.recipe

I already gave up on this subject. I wiped my Haiku VM, reinstalled eveything. Ok, Glib2 was finally found.
Yeah. But: haikuporter, regardless of both “a gentle introduction to…” pages crashes with : recipe doesnt have a signature. (good luck finding that in Google). In the screen output just before the error: it decides to skip validation of a certificate, which might be the reason: No certificate to validate a recipe, then a safe position is not installing it.

The issue: haikuporter isnt ready for prime-time. I didnt have this issue the first time I installed haikuporter. But a new install of Haiku, a fresh install of haikuporter, and a new “random” error where google doesnt offer answers to the question: how do I fix this… Its either my bad mojo, or package management and porting software isnt reliable yet.

People that write: there is a recipe for that, simply ignore that it somehow needs a complex system to make it work. Thats why most distributions ship standard binaries.

That’s exactly what Haiku does. Only that as long as we don’t have buildbots that churn out the HPKGs that are available through HaikuDepot, there are more working recipes than HPKGs available. Things on that front are moving forward though.
Until it’s all automated, it’s either “build from the recipe yourself” or “wait until someone builds and uploads the package”.

It’d be easier to help you if you pasted your recipe and the exact haikuporter command line you use and its output. Maybe paste at a service like Sprunge.us because the output can be quite long…

how to use the recipe by myself? how to run that recipe? Just drag it in the terminal?How does it work out without reading a book?

It’s pretty much described at the HaikuPorts wiki. If there’s interest, I can write a little blog post about it.

Yes here is interest following a small easy (for me:blush:) tutorial or blog… without using external links…

I would be happy to read a simple how to about using a recipe! I read the HaikuPorts wiki already… Its a long read with lots of look here click there… as described here “link” follow the blog here and so on…

Just a small simple example would do like:
"How to use a recipe if you get one"
for example.

…really needed as I am still try to compile some simple code and then use
gcc sample.cpp or g++ sample.cpp

Standard g++ helloworld.cpp works from the terminal.

The examples found here are very helpfull


I will describe how I got haikuporter running, up till the point that all compiles fail or signatures can not be found. Setting up Haikuporter is a straight forward job when you follow the wiki.

Type this in the terminal:

Once you have done these things, you can in theory do

  • haikuporter -S mpg123

Initially haikuporter will start updating all packages it finds.
Beyond this point, I never got haikuporter to successfully compile an application.

Perhaps a stupid question: why cant people that compile Haiku packages, upload them to an archive?
Sure, you will need user management but it saves a lot of time and resources. People only need to indicate the architecture for which the package was compiled.

You need to use the --get-dependencies switch to haikuporter, so it builds just what you asks it to. Otherwise it will build the whole universe, which is never what you want.
As for package repositories, it is rather easy to set one up, and several people have done so. The Haiku project currently does not have enough manpower to manage such an open repository, so we leave this as a 3rd party effort. Kind of a bebits replacement, but using packages.