Missing Codecs

Since MediaPlayer wouldnt play MP3’s, I tried an experiment. I booted back into BeOS MAX and tried playing the same MP3 and it worked with out error. When I try to play it under Haiku it gives an error message about “missing codecs”. If theres a codec pack somewhere that needs to be installed a pointer to it would be appreciated. Thanks.

Its likely a problem with your audio card and the system driver. Can you please tell me what card you have ?

Does VLC work ok?

I fixed it by un-selecting the last two check boxes in Media prefs. And VLC wont work on this nightly build. Hmmm…knowing all that I’m very tempted to put PCLinux back in the drive bay. If only linux had the charm of BeOS/Haiku…sigh

this is a little perplexing as I have not had any problems whatsoever with media playback with mp3 wav etc formats. Just flac files usually. Some play, some don’t. You should make a bug ticket.

What nightly build are you using ?

Haiku is not meant for end users until it reaches late Beta. Haiku is mostly good for playing around with right now. Still needs more work to get finished.

You should dual or triple boot. That’s what I do. You should use Linux or Windows as your first OS and can switch to Haiku sometime later when more ready.

I got a mp4 movie to play on Haiku by downloading it from youtube first. Funny thing is media player still wont play mp3’s. Complains about the missing codec. Also BePDF isnt available yet for the nightly builds? I tried to install that but it said “not available”.

what version of haiku are you using ?

One of the nightlies from last month. Its a gcc-4 version so i guess thats why BePDF wont work. i bet the mp3 issue is that mp3’s are a closed format with licencing issues? or the guy working on the media player and codecs has’nt gotten to it yet. that said, its working rather well on mums HP dv6433 laptop. wireless works too and my AP dos NOT broadcast its BSSID but is in “shadow” mode. i had to assign a static IP in the router and write a line at he end of UserBootscript, but it works. It takes a minute or two to attach to the AP. in network preferences i used static mode. also, anyone having problems should be sure to change the default to

try a newer nightly. sounds like something was wrong with the build or the iso image.

Hi all,

same symptom, different reason. I updated to 41421 a week or so ago, and have found that MediaPlayer won’t play mp3 files. I ran from the terminal and got:

~/Desktop/cats> MediaPlayer 01_-Various_Artists-The_Moments_Of_Happiness(UK_1981__Musical_Cats).mp3
open playlist item: 01_-Various_Artists-The_Moments_Of_Happiness(UK_1981__Musical_Cats).mp3
[mp3 @ 0x180d1830]max_analyze_duration reached
[mp3 @ 0x180d1830]Estimating duration from bitrate, this may be inaccurate
PluginManager::CreateDecoder: can’t get decoder for format: Bad media format
MediaFileTrackSupplier: track index 0 has unknown type
Controller::SetTo: InitCheck failed

I tried to copy the file to a short name (aaa.mp3) and got the same result. VLC, mplayer and ffplay all play the file correctly. Have I messed something up? My current system is an “upgrade” from the previous (ie installed on top of previous), however I have also tried straight from the live USB with no luck.

My system: eeepc 701 2G ram
haiku version: 41421, running from 4G sdcard.
in case it helps, md5 sum is: b507cd2275a9ca9524c9fa7eaaeb4864 /boot/system/apps/MediaPlayer


I never have these problems and I update my machine all the time.

sounds like a file copy issue or a buggy hardrive.

My eeepc has an SSD, and the file plays fine using other players. I also tried the raw image (dd’ed to a USB) with the same results.

Good to hear that the update process probably hasn’t hurt anything. I was reading through forum posts and bug reports which mention that mp3 support was changed in 38403 (http://dev.haiku-os.org/changeset/38403). Could this be the problem? VLC, ffplay and mplayer would all decode the file themselves, so wouldn’t use a translator, or built in haiku lib.

Could it be that my mp3 files have some incompatible codec? They are downloaded from OVI music store.

Not a real biggy, as VLC etc. will play them, just would be nice to use the built in player.


Start a ticket in trac and attach one of the mp3 files.

This says it all:
PluginManager::CreateDecoder: can’t get decoder for format: Bad media format

It is having trouble deciding which decoder to use on that mp3. You will have to file a bug to have it looked into.

Do you have other mp3s not from OVI store to test with?

Upgrading should not cause any issues except when

  1. your partition has become corrupted (use checkfs)
  2. you try switching from gcc2 to gcc4 Haiku or vice-versa using upgrade

Hi all,

Thanks tonestone57, I investigated some more, and it turns out I must have installed a gcc2 version many moons back. There were old libs which were interfering with the gcc4 hybrib install. It also turns out that if you automount BeOS file systems, it can use those libraries. My USB stick booted, by my SD card was still inserted, so it picked up the old libs. Remove the SD card, and it all worked. I backed up, wiped my SD card and reinstalled from the USB and everything now works.

Thanks to all for their help.

PS its hard to format a Be system thats been mounted - you can’t unmount it if any lib has been used. As a tip, turn off automount, reboot and format using DriveSetup. Once mounted, its very difficult, well it was for me :slight_smile:


Hi all,

was playing around and installing some apps, when the same problem (MediaPlayer not working) occurred. It turns out that it is not a library problem at all - I spent an afternoon comparing libraries etc. It was just a “fluke” that reinstalling fixed it. What seems to happen is that (I am guessing) MediaServer doesn’t startup properly sometimes. Probably about 10-20% of the time on my system. There is no indication that this has happened other than MediaPlayer not working. Other apps (eg VLC) still work. The fix is really simple. Restart the MediaServer, and everything starts working. There is no indication of a problem - I’ll try to troll through the syslog later.

I don’t know if it is actually an internal MediaServer issue, or another app which is causing the fault. When MediaServer is restarted, whatever is causing the fault seems to be cleared. Sound still works (as VLC will play files), just no haiku decoding. Hope this makes sense. Is it worth a bug report?


Vader, are you using a recent nightly?

Try running checkfs from terminal and see if there is any corruption in your file system. Could also be something blocking MediaServer from properly starting up for you.

You should file ticket for the issue but only when testing with a newer release of Haiku. You may want to wait for Alpha3 which should come out in next 1 to 2 weeks.

Also, first search through the tickets and see if anything similar to this issue.

Include syslog with any ticket you file.

Hi Tonestone57,

I am runnning 41421 (May 10) gcc4 hybrid, so relatively new. I’ll wait till alpha 3. Apart from this minor hiccup, haiku is working really well on my little eee.