Missing 'bookmark bar' at the Webpositive browser

Hi, I’m new on Haiku (made some first steps decades before on BeOs) and try to find and prepare an browser which is similar to Firefox for example. Especially a boorkmar bar I like very much to see all favorites with one view.

So Webpositive shows the possibility to configure a ‘bookmar bar’ under “view” → “show bookmark bar”. But choosing this possibility nothing happens … no bookmark bar is being visible!

What am I doing wrong?

Or is there a better browser concerning bookmark administrating?

A second problem I have with Webpositive is, that once opened browser tabs won’t closed closing the browser (and restarting).

Thanks a lot and have a nice weekend!



1 Like

Welcome to the Haiku community :slight_smile:

Are there any bookmarks in the bookmarks bar? You can check this by looking at the contents of the folder /boot/home/config/settings/WebPositive/Bookmarks/Bookmark bar or in WebPositive in the bookmarks menu under “Manage Bookmarks” (or something similar, I’ve translated it back from German)

Dank Dir, Blue,

nein, das Verzeichnis Lesezeichenleiste ist leer. Was ich nicht verstehe, ist, dass die Lesezeichenleiste oben im Browser nicht erscheint, wenn ich sie per Auswahlklick anlege. Im Firefox erscheint ja oben eine zusätzliche leere Leiste, die sich dann beliebig von links nach rechts füllen lässt.


Thanks to you, blue,

nope, the bookmark bar directory is empty. What I do not understand is that the bookmark bar at the top of the browser does not appear when I try to attach it by selection. In Firefox, an additional empty bar appears above, which then can be filled from left to right.

Gern geschehen. Lass uns bei Englisch bleiben, wenn das für dich passt. Dann können auch diejenigen die kein Deutsch verstehen mitlesen und evtl. was beitragen :slight_smile:

Try putting some bookmarks into the bookmark bar folder. You can copy or move some of the default bookmarks or create your own from the bookmark menu (or Alt+B).

Welcome Camouflage.

Related tickets:
#13239 - Web+ bookmark bar disappeared
#15928 - Web+ bookmarks bar toggle should update according to status

1 Like

Ok, I just could transfer two ‘normal’ bookmarks by moving into the bookmark bar folder. But the result is unchanged - no visble boormark bar at the browser window and no possibility to create one by cklicking view → show bookmarkbar …

Any idea?

Thanks a lot


Thank you humdinger for your friendly ‘welcome’ and the links.

I am afraid it doesn’t help. Maybe I just don’t undestand the hint …

Ticket No 13239 explains how to make the bookmark bar disappearing ? But I want to make it appear :slight_smile:


This answer tells you that this problem is known and in progress, or at least reported. So it doesn’t work now.


I moved some bookmark in the manager with drag&drop into the bookmark bar and that works.

Not really. This is clearly a known bug you are experiencing, as evidenced by the open tickets in the bug tracker. The only thing that comes to my mind you could try is deleting the WebPositive settings completely and checking if it works correctly afterwards.
To do that you have to go to /boot/home/config/settings and rename the WebPositive folder (so you can restore your settings if you want). Make sure WebPositive is closed while you do that. At the next start WP should create a new settings directory.

1 Like

Here too. I had to hide/unhide the “Bookmark bar” twice fo it to appear though.

1 Like

Hey, now I managed to kill my bookmark bar too… :slight_smile:
I was able to restore it by quitting Web+ and deleting ~/config/settings/WebPositive/Application.


Could this stuff please be put into a ticket? It’s really hard to follow on the forum…

1 Like

I may have tripped into #13239 above… :slight_smile:

That one discribes the problem. On first launch, the folder ~/config/settings/WebPositive/Bookmarks/Bookmark bar is empty. Web+'s bookmark bar is empty and just shows a “…” menu with an [empty] item. If you then choose View | Show bookmark bar, the bar disappers and won’t reappear when choosing View | Show bookmark bar again.
It will work however, once you added some bookmarks to the “Bookmark bar” folder.

I commented as much on that ticket.

1 Like

Sacrifices have to be made in the name of progress :wink:

1 Like

I can copy bookmarks into the bookmark bar folder in webpositive settings folder. This booksmarks displayed and open the coresponding website.


I do not like, that the complete name ist displayed of the bookmark, so you can not place so much of them.

1 Like

You can rename the booksmarks to make them shorter.

The idea in the code is that the bookmark bar can be hidden for two reasons:

  • There are no bookmarks to show
  • The setting to hide the bookmark bar is enabled

This isn’t fully working as you can still manage to show an empty bookmark bar, which should never happen.

It is also confusing if you are playing with the setting and also have no bookmarks in your bar. You can end up in a situation where the bar is disabled for the two reasons at the same time, and so you need to both add some bookmarks, and enable the bar in preferences, to get it to show again.

Any suggestions on how to make this less confusing?

1 Like

My solution would be to show the empty bookmark bar if the user enables it. And make the bookmark bar hidden on a fresh install (this is already the case if I remember correctly).

We could also place some default bookmarks into the bookmark bar so it isn`t empty when a user first enables it.


+1. Nothing wrong in showing an empty bookmark bar. Avoids confusion of a disabled “Show bookmark bar” menu item.

Not a huge fan of that. But we could have an item “Manage bookmark bar” in the “…” menu of the bookmark bar. It should always be the last item there, below a separator. It’ll open ~/config/settings/WebPositive/Bookmarks\Bookmark\ bar.

Better might be to have an “Add this page to bookmark bar” instead. But we’d have to give the user the opportunity to edit the file name of the new bookmark, because they need to be short to fit many into the bar.
We could just open ~/config/settings/WebPositive/Bookmarks\Bookmark\ bar in Tracker and select the newly saved bookmark in edit-mode. The bookmark bar auto-refreshes already.