Minor UEFI Booting Issue - Boot volume not available

Hi, i just installed the latest Nightly on a UEFI capable machine by following the instructions in the Guide (https://www.haiku-os.org/guides/uefi_booting/). Works in general as expected, but i have a minor issue - i need to select the Boot volume at every boot, even if it looks like it’s detected.

My setup is simple, there’s only one SSD in the system, which is GPT partitioned and has two partitions (EFI System Partition, Haiku OS).

The Boot Manager shows the following immediatly after power on:


It detects the Haiku Partition, but i can’t boot. I have to first navigate to “Select boot volume” and reselect the Haiku Partition there:


Now back on the main menu, i’m able to continue:


Any hints on how to fix this, or is this maybe a Bug in the EFI Bootloader?

It’s not really a bug in the loader. It’s just that efi-loader is not feature complete yet. So right now I don’t think you can do much until UEFI booting is improved.

Use the efi file from beta2,


That worked, thank you!

This is the bug report: https://dev.haiku-os.org/ticket/15049 and despite multiple requests no one has submitted a copy of the bootloader log (from the version that doesn’t work), which makes it difficult to investigate this any further. It would be great if you could take the time to do that.

I had the exact same problem yesterday after re-partitioning my disk to support EFI boot. Unfortunately I haven’t seen the reply above so I experimented by myself.

The only info I can provide that could maybe help is that I resolved it by putting the FAT32 EFI partition AFTER the Haiku one in the disk. Just because I noticed that USB stick was using the same layout and thought of trying it. USB stick was an older nightly I had around, hrev54945. Nothing else worked. So, this works in my case. But I noticed that if another external USB disk is attached then the problem appears again. All partition work was done with Drive Setup from USB stick.

Also not thought about checking boot loader log…

Appended two Screenshots containing the Bootloader Log of hrev54978 (which has the issue) into the Bug report.