Mini desktop machine for Haiku?

Wlan shows up as device in uefi mode for me too, but the driver fails to initialize it, even with csm enabled.
In legacy mode it works as it should.
This is with intel 7260 wlan.

Yes, the UDOO x86 II uses Realtek audio/Ethernet chips compatible with Haiku. :grin:

Create a bug report for your Ethernet and/or Wifi (if not already done).

Update on audio/ethernet/wifi hardware used:

  • Realtek ALC-262/ALC-263 audio chip
  • Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
  • Intel Dual Band Wireless-AC 3168 802.11 ac 1x1 WiFi + BT 4.0 Combo Adapter [8086:24fb] (rev 10)

Yeah… but, again, so are the ones in the Kodlix I have.

I do have bugs written up, so no worries there. Waddlesplash has tried to get it working (while fixing other things).

But I will try (or retry) the legacy boot again. Maybe that’ll do something.

I never meant audio, just wlan. There is slready a ticket for uefi+wlan firmware uploading problem.

Hi,

I have bought the Upboard, but the second generation (Up Squared) in its atom e3950 version.
I added a mSATA SSD, it is natively working on Haiku.
HDMI/DisplayPort are working (Vesa mode), ethernet is working (both ports).
I have not tested Wi-Fi, but as you need to populate the dedicated slot you must install a Haiku compatible Wi-Fi chip.
For sound, only DP and HDMI is available on this platform and it does not work on Haiku.

Regards,

Eddy

1 Like

Nothing good in Legacy boot mode. Changing various settings under CSM (EUFI, Legacy, Do not something or other) results in either the device not showing up at all, or showing up but without a MAC address and other required things.

Reckon it’s back to looking for verified systems.

Hey, I think you mentioned wifi worked on Beta1. Are you testing a more recently x64_64 nightly (hrev53350+)? I don’t know if the most recent bug fixes for idualwifi7260 were added, but saw that
the driver worked with the same hardware in the UDOO hardware (and yours) in UEFI/legacy modes.

I use a similar realtek ethernet driver/chip on my x86_64 system. Does your ethernet/wifi hardware work fine with another OS in legacy/UEFI modes? Updated BIOS? :wink:

I don’t think that was me. As far as I remember, Wi-Fi never worked on this thing. It never even shows up as a device.

Kodlix never made an updated BIOS for this box. I had another problem where, no matter what I set the primary video to, all boot/BIOS/EUFI displays went to SVGA and not HDMI which made things super difficult when trying to select a boot device or mess with BIOS settings. They gave me an ‘updated’ BIOS that was exactly the same as the one already on the device. So I use an SVGA to HDMI adapter, but lose out on 4K resolution.

Wi-Fi and Ethernet work fine under Windows and Ubuntu no matter what the BIOS is set to. However, neither work using… I’m going to say FreeBSD? Wherever the Haiku drivers come from. I tried a live CD (or USB) of that, and it didn’t work there either. I think that’s where the real problem lies.

About once a month or so I boot an earlier version of Haiku that works with a USB to Ethernet adapter I have and try updating to the latest nightly to see if some magic happened.

If you ask why I don’t just use the USB Ethernet, it’s because it stopped working when Waddlesplash fixed a problem that solved a lot of other people’s USB Ethernet problems :smile: I have another USB Ethernet which has an AXIS (I think) controller, which I also thought Haiku supported, but that doesn’t work either. I’m pretty much convinced it doesn’t want to work with Haiku.

It’s not a total loss, though. Mostly I use it for remote using my work desktop, and it’s great for that and leaves the other computers open for doing other things. So I don’t mind getting another [working] one if I can use it solely for Haiku.

Did you retest this recently? I made some more fixes to those fixes and asked people to retest, and nobody yet has that I know of. There was also a major fix to the ASIX driver which may help out here.

I tried it about a week ago. I’ll give it a whirl when I get home. I can check out the ASIX one in a few minutes,

KERN: usb_asix:00.07.948:init_driver::ver.0.10.1
KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/net/usb_asix

listusb does see it:
0b95:1790 /dev/bus/usb/0/5 “ASIX Electronics Corp.” “AX88179 Gigabit Ethernet” ver. 0100

Just tried it and that’s what it says for ASIX, yet the device doesn’t show up. But I’m running hrev53353, which I don’t even see on the Nightly page (I see 50 and 54). Also, this one is a virtual machine so maybe it’ll be different on bare metal.

I’ll try it on the Problem Child when I get home.

Small?
small are arm machines or risc-v

Read the opening post next time, as i search for not just small but supported hw, what we can’t say neither about arm nor risc-v.

Haiku list verified (everything works):

  • 1.4GHz, VIA Nano X2 E-Series ($50-$69 USD, Nano-ITX, 64-bit)
    • You can get these as 1.46GHz VIA QuadCore E-Series, 8GB RAM
    • VGA/HDMI (A/D) converter adapter (if you need it)
    • VE-900 model confirmed, VX900 compatible

I had a client box with this motherboard. Ran fine for years until a power surge…

3 Likes

Those VIA nano’s are going to be way too slow for many tasks though… half as fast as even a slowish AMD A4-5000… which is the slowest system I’d ever recommend for any modern use and even then only with a sata SSD.

An i3-8100 is about 7-8x faster…

You can buy the Udoo Bolt from mouser they have them in stock… personally I’d go with an Asrock A300 deskmini though… should be basically the same since it is the same chip. And the A330W is upgradable unlike the bolt.

Almost. From what I can tell, the Bolt uses a Realtek RTL8111G and the Asrock uses the RTL8111H. For an officially supported driver, it may not make a difference but for this it could make or break it.

I thought there was another thread here where someone had an H that wasn’t working, but I can’t find it right now.

Probably both will work equally badly if at all realtek chips are notoriously buggy… but the re driver doesn’t advertise support for exact chips very well neither is explicitly supported. You may even find you can get a supported version of the ASIX USB ethernet that may be more stable.

If it doesn’t work on Haiku you should also test with the latest FreeBSD and report back to waddlesplash via dev.haiku-os.org (create a ticket if one doesn’t exist for the chip in question) if it does work… potentially he can fix it.

@waddlesplash the bug report in freebsd here someone mentions that the driver always allocates jumbo frames even when not receiving them… so can severely fragment memory over time. Seems like it could be a situation where 2 birds could be killed with one stone if the Haiku port of the driver has the same issue.
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=236962

It does not work on Haiku, if anyone is interested.

I take it back, it does work. So I now have Haiku installed on an ASRock A300W with a Ryzen 5 3400G and working Ethernet. Rocking at a too-high 4K resolution because I can’t get it any lower. But I got my network connectivity, so I won’t complain.

Care to elaborate on why you thought it wasn’t working? Also… why don’t you have lower resolutions available?