Media Player not playing anything

Just did a nightly install. Media Player will not play any file, not any audio (mp3, ogg, wav) nor any video (divx, mpeg, avi) that I have. All of the files I have tired worked just fine before.

I downloaded VLC, using Haiku Depot, thinking I could use that. But that app crashes immediately upon opening. So, it seems there is no way to play any media at this time.

I have log files and a screenshot of the problems I am having. But I am no longer able to log into Trac and am having problems getting my password reset. The password reset I think is being worked on. But, if someone wants to take a look, at my Media Player/VLC, I can send them the files directly. I would appreciate the help.

Did you update or install from scratch on a clean partition? I suspect that /boot/home/config/settings was left on the partition. if that was the case, play with media settings, I think there was a change with how the media server reads the settings file. I had the same issue untill I changed, saved, and changed back the media settings.

I initialized the disk before I did a clean install so there should have been nothing left. That said, I opened media player and opened the settings dialog and made a change and saved it. I then tried to play an mp3 but still have the same crash.

I still have the files I to send to someone.

That would be media prefrences, [leaf], [Pteferences], [Mediia]. Give that a try first.

Which version of the ffmpeg package do you have installed? 1.10.14-1 was working only with MediaPlayer. I uploaded VLC and a 1.10.14-2, which worked only with VLC (and not very well). Then I uploaded 1.10.14-3, which works for both here. Make sure you have that version installed.

@ PulkoMandy - I did a clean install from a nightly (hrev49112) so I have installed what came with that. I am not sure exactly the best way to determine the version. But, if I go into HaikuDepot and look for ffmpeg it says 0.10.14-2. Haiku Depot only lists that one.

again I have a screenshot of the error and the crash log, but no way to get a bug report written.

It is listed here:

Try use the contact form, so someone with the right permissions can email you a temporary password:

I’m sorry I am a bit confused. This like just seems to be a listing of different ffmpeg versions. It does nothing to expaline how a clean install seems to have put the wrong version into my system and I still have no idea where to get the correct version or how to install it if I got it.

You simply got a nightly from before the fixed package was uploaded. You need to update the ffmpeg package using “pkgman update ffmpeg” after configuring your system for rolling updates as mentionned here:

@PulkoMandy - updating ffmepg has resolved the Media Player issue. I am still having problems with VLC.

Yes, VLC is still very “experimental”. I will get back to this, for now you can give it a 1-star rating in HaikuDepot :slight_smile:

Thank you for the reply.