Making screen resolution automatic

I have a 4k screen, which makes screen contents too small for old eyes. So, I hit the spacebar on boot and select 1600x mode and all is good. Perfect. How do I automate this so I don’t need to hit the spacebar every time? The Screen preferences app only shows the 4k option when I don’t press the spacebar on boot.

Have you tried increasing the font sizes (and desktop icon sizes)? That should scale everything up, although I think you have to reboot after doing that before changes will be seen throughout the GUI.

1 Like

Thanks for the suggestion. I’m looking for the lazier approach to this. Am wondering why the other resolution modes do not show up in the Screen app. Haiku is running in framebuffer mode, probably due to some odd graphics chip on my board. Perhaps I missed something in the Haiku loader menu, although the loader may not have a place to store settings. It’s no big deal, and Haiku Depot apps are mostly “just working”. As I said before Beta 4 is really starting to shine.

You are booting with efi and using the efi framebuffer driver. In this case the bootloader has to set this resolution, i’m not sure there is a setting for this.

Increasing font sizes is the normal aproach and should work. If it does not for some apps feel free to open a ticket.


I think the efi framebuffer driver can load parameters from the vesa config file. Uncomment the mode line, write your preferred working resolution and bit depth, put it in ~/config/settings/kernel/drivers, cross your fingers and reboot.


Hi Madmax, the added vesa file worked perfectly. All automatic now. Thanks!

1 Like