Mail throwing General system error when checking for incoming

I have slowly been setting up my Haiku B2 installation and was setting up my email based on the exact settings from my Haiku B1 installation. Checking for incoming email results in a General system error. I have even copied over my settings from Haiku B1 to Haiku B2 and I get the same result. Anyone else having issues with Mail?


Try to fiddle around with the:

  1. Connection Type to no encryption

  2. Login Type to Plain Text
    and insert the path to your incoming mail and outgoing mail manually again.

  3. Look again for help:

I have fiddled around with various settings and still no luck. Checking email works fine on my Haiku B1 installation with the same exact settings. MailNews on my Haiku B2 installation also having no troubles checking email with the same POP settings.

Did you try to set the path to your incoming mail manually?

I did. I’ll play with it some more this week.

I decided to revisit this issue and can’t for the life of me get this working. I can get outgoing mail working without issue. I just can’t get incoming mail to work.

Did you have a ticket for this problem? Have you run the mail daemon in verbose mode? Have you attached its output to the ticket?