Macintosh "classic" emulation?

Does anybody care to compile new working executables for BasiliskII and SheepShaver?
I am aware of the SS-2.1 and BII-0.9 BeOS builds, but those dont work for me with HAIKU.
I dont have skills nor knowledge to compile new files myself, unfortunately.
I would really like to see a SheepShaver entry under the blue leaf, because HAIKU consumes so few resources and is very responsive,
certainly one of the best OS I have seen ever.

I only see BeOS PPC for Sheepshaver. For BasiliskII I see both BeOS x86 & PPC builds. I don’t think there was ever any Sheepshaver BeOS x86 build available.

Sheepshaver would require additional coding to have it working on x86 Haiku. I think just compiling won’t be enough. BasiliskII should require only some minor fixes + compile to work on Haiku. It should be the easier one to update for Haiku.

I’m only guessing from the information I saw because I haven’t tested any of this out.

No idea if this works on Haiku:

That version was way out of date though. The last BeOS supported version was 0.3.1 apparently, but I can’t find it.

I remember this emulator was huge news when it came out. Unfortunately, one of the lead developers died and never progressed much after that.

Nice find Karl but PearPC isn’t for Mac Classic OS (7.5-9.0).

Basilisk II: 68K processor - Mac OS 7.5-8.1
SheepShaver: early version of PowerPC (Power Mac 9500?) - Mac OS 7.5-9.0
PearPC: PowerPC G4 - Mac OS X.

G4 CPU is supported by Mac OS 9.2.2 (& maybe an earlier version or two) but seems to not have been possible yet to run OS 9.2.y on PearPC.

Very few G4s could run Mac OS 9.0 & 9.1 and support for G4s was added in 9.2.1 & 9.2.2

I also see that mmu_man made 26 commits to PearPC so I’ll assume his BeOS code was merged in already because changelog was not viewable to confirm.

Edited to fix minor error

whoo whee. I remember back in the day when I though SheepShaver was the bees-knees (ok, I’m not that old)

The code of sheepshaver is really messy. I have a hacked version on my Haiku box that almost compiles. If it ever gets beyond that I will post the changes and the binaries.

Karl you must be the first and only one then. =)

I think you may have used SheepShaver instead. I’ll tell you why.

  1. I searched for 15 minutes and could not see anyone successfully run Mac OS 9 on PearPC. No articles, forum posts or screenshots to prove this was possible or worked.
  2. PearPC FAQ says “Can I run Mac OS 9.x.y? So far no one has succeeded in doing that. Have a look at the forums.”
  3. PearPC Wikipedia entry only lists OS X. No OS 9 support listed. If OS 9 worked then someone would have updated the info here.
  4. Forum posts saying OS 9 not working on PearPC:
    August 2010:
    Can it run Mac OS 9? - E-Maculation
    May 2009 (read this one & following posts):

PearPC is used only for PowerPC version of OS X. PearPC is unimportant today because of Intel Macs (hackintosh) and no Classic OS support.

It doesn’t work because I’ve seen some posts saying it was missing opcodes in the emulator:
“PearPC won’t boot/install/run OS9 because this OS relies on OpenFirmware opcodes that aren’t implemented in the emulator’s source code yet.”

I have tried to port MiniVmac on Haiku.Unfortunatly, MiniVmac Sources are written in C and I don’t know how to mix C and C++ sources.
Is it possible to open a window on haiku with a c program (and not a c++ program) ?

I have run OS 9 on PearPC, I can’t remember the exact revision.

@katilisi - be nice to see sheepshaver on Haiku!

@tonestone - maybe it was sheepshaver then; was a couple years back.

I succeed in compiling Basilik II on Haiku. Unfortunatly, the fpu emulation based on asm code cannot be compiled in haiku. Don’t know why ?

If your build is working so far, I would like to try it.
Could you provide a link please?

What error do you get? What are you using to compile and link the ASM?

  • Andrew

Here is a link

I have modified 3 things to make the Beos code works:

  1. CAM.h needed by scsi_beos.cpp is in the device directory (not in driver anymore)
  2. I have commented the use of unmount in sys_beos.cpp
  3. I have modified the Makefile because of an asm error when using fpu_x86.cpp.I use fpu_uae instead.

Nice Job! =)

I compiled my own but you should upload yours to Haikuware for others to use. In regards to your #1, #2 & #3.

(1) Ok - CAM.h now in other directory.
(2) You should use unmount to avoid any program instability. In sys_beos.cpp include following code to get unmount to work:

#include #include

int unmount(const char *path);

int unmount(const char *path)
return -1;

(3) No fix for fpu_x86.cpp. Not sure about defining variables with inline assembly code.

Graet. It’s now just waiting to use the FPU in Basilisk 2 and the port of SheepShaver for Haiku x86 - we have port only for BeOS PPC.

FPU should work in Basilisk 2. He still compiled FPU into it but using fpu_uae and not fpu_x86. Both of these provide 68040 fpu emulation but fpu_x86 should run better because partly written in assembly code. Of course, computers are very powerful today so you really would not notice the difference.

fpu_uae is coded in C++
fpu_x86 is coded in C++ and Assembly

From fpu_x86.cpp:

  • fpu_x86.cpp - 68881/68040 fpu code for x86/Windows an Linux/x86.
  • MC68881/68040 fpu emulation

From fpu_uae.cpp

  • fpu/fpu_uae.cpp - the old UAE FPU
  • MC68881/68040 fpu emulation

Thank you so much sys6502! Your build is running with HAIKU in VB4, looks fantastic.
With my set, BII seems to boot only with a 10Hz or 15Hz refresh rate.
Windows above 800x600 seem not to work, fullscreen looks terrific, but BII doesn’t seem to catch the mouse from XP > HAIKU > Mac.
I am using the System7.5 image from Macintoshgarden and a Quad650 ROM from Redundant right now for playing a little.

tonestone57: ahh, sorry and thanks for drawing my attention. Then we waiting on SheepShaver and/or PearPC(MacOS PPC or MacOSX PPC) for Haiku. BTW. I’ll get to test Basilisk 2.

Not your fault. I saw same message on Haikuware. Basilisk pretty much compiled. It needed few lines of code changes.

I don’t think anyone coded Sheepshaver for x86 BeOS. It would be lots more coding to get this working unless they updated the code for Sheepshaver from Basilisk. Still worth someone trying to compile Sheepshaver to see what happens.