Macbook 2015 compatibility?

Hey all,

Been a while.

I’m being gifted a Macbook from 2015, and I’m curious about compatibility. I could just run it in Vmware or something, but if it ends up being something with minimal ram, I’m inclined to install something else, hence my question.

Do any of you have any experience with that year’s models with Haiku?

If it’s a MacBook retina 12” 2015 then keyboard and trackpad do not work because they are wired to the SPI bus that Haiku does not support atm.
I have a 2017 variant where the Intel graphic card is not supported either but works in vesa mode (framebuffer actually).
The Wi-Fi does not work either. I don’t remember the specs of the 2015 model but chances are it is similar to mine.
IMHO, this is not the best option to run Haiku

1 Like

Thanks for the quick reply. I could just as well run it in VMWare Fusion then. Best of both worlds in a way.

Have you already tried this? I remember that mine doesn’t support virtualisation due to the low performance CPU. It was a long ago though and I might remember uncorrectly

1 Like

I got one of these and the response is helpful if not the news I would have wanted - as Apple support will fall away soon. Whilst sticking the Haiku in the USB didn’t boot, I think a Genode USB image loaded first time but with problems similar to that you mention.

It does, indeed. The caveat is that you need to find a good combination of USB thumb drive and USB-C multiport adapter. I used to boot it with a Port Designs (Port Connect Professional Docking), a Kensington thumb drive and a Logitech unified adapter for mouse and keyboard plus a TP-Link nano Wi-Fi adapter. It worked well but was painful…

Oh and obviously I needed rEFInd

I run Beta4 in VMware on my mac and it works fine.

Do any of you have any experience with that year’s models with Haiku?

I’ve got a mid-2014 MBP with iGPU and run Haiku in a VM.
Haiku boots via rEFInd on bare metal but the screen is unusable. Only a blue stripe on the left and top. Getting into the boot menu and selecting safe mode or disabling any of the other option doesn’t make Haiku to boot properly on my machine.
Until I figured it out, it’ll need to run virtualised.

In Virtual Box it’s limited to a screen resolution of 1600 x 1200 and runs smooth with 2 cores and 4GB RAM.

In Qemu via CLI on the other hand it runs rather slow with 2 cores and same amount of RAM but screen resolution can be as high as 3840 x 2160. I reckon it’s slow because the CPU is emulated by software whereas Virtual Box utilises the machine’s CPU.

In VMWare Fusion 8.5 on OSX10.15 I don’t get anything on the screen at all. The machine’s display remains dark, only the thumbnail in Fusion’s machine library shows the output, no matter what the machine’s display settings are. Can’t get the boot menu to show either.

Edit: in regards to Haiku on Qemu I found this post: Qemu on MacOS Host - rather slow performance in Haiku Guest

The integrated GPU (intel) on these MacBooks, although in theory supported have some issues. You need to enable the fail-safe graphic driver.
Safe mode and fail safe graphic driver are two different things.

If it’s a MacBook Pro 2015 then yes, it’s possible:

1 Like