Local Package management

hello all,

i have many .hpkg file that come from testing haiku nighlty… and i dont want to reconnect again to internet just to download .hkpg that i have been installed (sometime failed , slow network… etc).
My question is can the collected .hpkg file use for local repository (like use opensuse DVD as local repo for yast for example)…
any suggestion is really appreciated


Yes, just doubleclick on it. It will open up in a HaikuDepot window and then you can click on “Install”. The only catch is if that hpkg has dependencies that need to be installed first, in which case it will put up a dialog.

Alternatively, just move (move, don’t copy) the hpkg to /boot/system/packages

To have a local folder recognised as an actual repository, however, would take some extra steps. First, create a repository on your local disk, then point pkgman to it. . See this recent thread on how to create a repo from a bunch of hpkgs . I’m not entirely sure that pkgman add-repo would recognise a localhost:// address, mostly becaue I’ve never tried. Anyone?.

1 Like

Hello mazbrili,

if you know with packages you have installed (all dependencies packages too), then you can copy them from /boot/stystem/packages on a usb stick or external harddrive. Then you have done a new installtion you can copy the packages to /boot/system/packages back and they will installed automatically.

You can use my backup tool “lbackup” to make this for you, but first here you need to create a custom config first too: http://software.besly.de

Tutorial: http://www.besly.de/menu/search/archiv/sys/lbackup_eng.html

Greetings Lelldorin


And now i have a default BeOS/Haiku way to solve your problem (finaly tested for some minutes).

Add the installed packages on a USB stick and then create of all this packages a link into /boot/system/packages on all your haiku installations. How long the usb stick is in the usb drive and automounted at startup your programs will be installed on all your haiku installations :slight_smile:.

Greetins Lelldorin

1 Like

thank you @lelldorin , @michel… your answer is very valuable for me and maybe other newbies…
right now. i’m playing haiku mostly on virtualbox so instead use usb i will use virtual disk for it
i’ll check one by one solution from you…

thanks all :smile_cat:

hi @lelldorin… i try your solution but lbackup seem cannot run on latest haiku nightly

… any hint?

sorry @lelldorin … after i install yab from haikuports right now lbackup can running…

hi @michel … it is very difficult to install application (haikudepot) from your repo… i’m try install fontmonkey couple of time but always error when download… but the value is varying… sometime 80+% and 98%…
is there any problem?.. for information: i can install from lelldorin repo and haikuports repo…

Maybe it was just bad luck with Michel’s repo and you have a general connectivity problem. Check your VirtualBox’ network settings.

strange, I’ll have a look. Can you go there directly and grab what you need?

Oh yes i know, i need to rebuild all packages… But i spend more time in developing new apps at the moment. Very sorry. But you got it :slight_smile: and enjoy.

Sorry, I can’t replicate that. I set up a nerw Haiku installation yesterday and my gcc2 repo works perfectly.

Besides, if there is a problem with a repo itself you should get a checksum error and no download at all. Maybe the connection to my server in South Africa was bad. My download speeds down here have fluctuated wildly the last few days.

yes, one can use a local directory for a repo. use the repo script linked to here: http://coquillemartialarts.com/fatelk/repo/repo.html in your directory.

launch poorman and set it to to serve the repo directory.

add in HaikuDepot > Tools > Manage repositories

in my case, poorman serves ~/public_html, and my repo is in: /boot/home/public_html/fatelk/repo/reposh/repo

I added “” and enabled it. This repo replaced the FatElk on-line version, but I could install loopdloop and have it install helpviewer as it is a dependency.

Your packages can now be installed through haikudepot and all the dependencies can be fulfilled from this repo.

1 Like

The cavet

One must have all packages form one on-line repo in the same repo directory.

The example.info name and vendor must match what was used for the on-line repo that the packages came from originally.

1 Like

@michel yes i can access it… it is weird too… i’ll try again today

@bbjimmy … got it. i’ll try this trick. thanks

@humdinger … maybe just bad luck… this moment i install aisee (small image viewer from classqm repo… it is installed and worked) when i try other application from classqm repo (anime) its not worked… seem failed to download like before. sometime (2 time this morning in my time haikudepot have been crashed)… and later i switch to HaikuPorts and install beezer… its finish and beezer installed ok. Finally i try to install bezilla from Haikuports and it is installed too…
little confusing… maybe just clasqm repo network connection intermittent problem for this case…