Libreoffice Dialog Unable to Gain Focus

I am unable to gain focus on a sub dialogue when setting up remote access in LibreOffice. This has previously worked as I have set up two (non working) SSH connections. Now I have connection sorted, I encounter this issue. Any quick fixes available to reset LibreOffice to defaults? I tried to uninstall and reinstall, but the issue persists.

Also, this is my first post, is this the best place for questions such as this. I have many more. :grin:

Uninstalling a package will leave its settings around. Try removing them at /boot/home/config/settings/LibreOffice.
WRT the actual problem, I’m not familiar with this option and would need the steps to take to try replicating the issue.

Welcome to the forums then, Rodney! :slight_smile:

Make sure to read the Welcome to the Help forum post. Generally, the Software subforum is for general questions on software running on Haiku, the Help forum for Haiku itself. I moved this topic.


I could recreate your issue after updating LibreOffice from libreoffice_x86- to libreoffice_x86-
Removing the settings did the trick.

1 Like

I can reproduce this issue. It looks like once you create SSH (or any other) connection and close Remote Files dialog you can’t create any more of them. Workaround is to delete ~/config/settings/LibreOffice/4/user/registrymodifications.xcu

Can you reproduce it under Linux with KDE5 VCL backend using this version?

Yes, that resolved my issue!

Yes, that is my version of LibreOffice

I meant can you reproduce it under Linux as well?

The version of LibreOffice I am running on my linux box is different than Haiku OS (Version:, there are no updates available. It is fine with a number of different entries in the “Open (and Save) Remote” I am such a neophyte that the conditions you have asked for are unfamiliar to me (KDE5 VCL).

KDE5 frontend (or VCL) in LibreOffice is only available for test pre-release on Linux.
You can download it from

LibreOffice doesn’t have KDE5 frontend.

1 Like

This bug was fixed in qthaikuplugins-

1 Like