LibreOffice 6.2 screenshots!


#1

To everyone who toiled to port LibreOffice 6 over, this is really incredible! And definitely worth celebration and cheers! I never thought that such awesomeness was possible in Haiku! For the first time since GoBe (or Calligra, which isn’t as good as LO, imho), it’s a real office suite! :smiley: I’ve successfully installed and launched it on my Haiku machine, and it runs really well.

Here’s a screenshot of the task launcher part as well (for those who haven’t tried LO on Haiku yet, it appears as one icon in the Leaf menu.)


#2

Is it still only available for the 64-bit Haiku?


#3

This looks very promising. :smiley: I look forward for the day when hardware virtualization will also be available, so I can actually give Haiku a serious shot on bare metal, on my main PC, not old scrap or inside VMs.

Is the LibreOffice port really fully ported, and is it expected to work normally for most tasks? This is a serious step forward for productivity with Haiku. Many thanks to everyone involved in this port! :+1:


#4

Yes, I still haven’t figured why automake (which is used to produce configure script for LO) fails on x86_gcc2.


#5

It is fully ported. But still have a few crashing bugs.


#6

That’s understandable, but still great news. :smiley: Thanks!


#7

I very impress!!


#8

Yay! I am waiting on the 32 bit build :slight_smile:


#9

Any news on a 32 bit build?


#10

apgreimann, how do you installed LibreOffice on your machine? I already try to install in my PC All-IN-One, 64 bits but it stoped before of to install the software … I used the “pkgman” command to do the install and downloaded half of the packages and, after, it stoped and I have abort the installation. Do you can help me???


#11

First, ensure your network connection is working and that you are running Beta 1. Second, make sure the system is up to date through SoftwareUpdater. Accept the changes, let it update, and restart the computer.

Once everything is up to date, either using the command line or the Depot (it may be easier just to find it in the Depot), install LibreOffice. I just tested installing LO6 on my MacBook Pro, and it downloads and installs fine. Although I do know Haiku has been working on the server, so there might an occasional drop, etc. but it should work fine. Hope this helps out; have fun with LibreOffice on Haiku!


#12

apgreimann, I did it! But see the result in the screen shot below:

freeze-update

How you see, it stop in the middle of the oparation … it happen to any installation (package to install) …


#13

I’m not an expert on packaging, so I’m not sure what else to say. Other than maybe try reinstalling Haiku and see if it’s still happens to you. Another possibility is the work that’s been going on with the servers; it’s possible that the packages may sometimes drop. Hopefully, someone else here will have a better answer than this. But I do hope that I helped.


#14

Could be a network related issue? Are you using a wired or Wifi connection?

if you try to manually download the package (wget <package_url.hpkg>), still get stuck?


#15

Hello un_spacyar!!! I’m using a wired connection and it works very well on the Ubuntu and Windows 10 … and I didn’t try to manually download the packages!!! Do I can download the packages directly??? Well I’ll try to do the download directly, so!!! After, I’ll post here the result.


#16

apgreimann, thank you for you’ll try help me with problem! Soon someone answer my question …


#17

Friends, I put the url from link of the package and the navigator doesn’t show nothing, only a blank screen, ok! The providers give to be off-line now … so, how do I get the package directly??? How do I use the “wget” command to download them? I’ll await your answer!!!


#18

@arcanjoebc1971 you can download hpkg files from here https://depot.haiku-os.org/#!/?bcguid=bc1-POXA&repos=besly,clasqm,haikuports,fatelk&arch=x86_gcc2&viewcrttyp=FEATURED


#19

see the result below:

---------------------- begin shell --------------------------------

Welcome to the Haiku shell.

~> wget -c http://buildmaster/haikuports/repository/master/x86_64/current/packages/libreoffice-6.2.0.0~git-19-x86_64.hpkg
–2018-11-16 02:43:25-- http://buildmaster/haikuports/repository/master/x86_64/current/packages/libreoffice-6.2.0.0~git-19-x86_64.hpkg
A resolver buildmaster…falhou: No address associated with hostname.
wget: unable to resolve host address ‘buildmaster’
~>
------------------------------ end shell -----------------------------------------------

But the connection is active, because I get to access the Internet … what do I do now?


#20

Hello! Open this url in webPositive (or your favourite browser):

https://eu.hpkg.haiku-os.org/haikuports/master/repository/x86_64/current/packages/

And look for the LibreOffice package. In WebPositive, right click with the mouse and select “Download linked file”.

Another way is:
Open the Terminal and type:

~> wget https://eu.hpkg.haiku-os.org/haikuports/master/repository/x86_64/current/packages/libreoffice-6.2.0.0~git-19-x86_64.hpkg

You will get something like this:

screenshot1