LibPango fails in Gimp

I’m trying to make a tilt-os account, but it doesn’t seem to work, so does anyone have any experience of Gimp failing to launch? When I run it, it says COuld not resolve symbol ‘g_realloc_n’ returned -214774780

Is an error like this cause by a wrong version of a library that doesn’t contain the right functions? And if so, is there any way I can download a new version of Pango without downloading a massive pack of libs?


Am I the only one that’s had this problem?

The problem is either:
a) wrong version of library which does not contain the right functions or
b) compiled with different libraries on Haiku

Compiling same library version on different versions of Haiku could also create different symbols depending on changes to Haiku’s libraries. For example, libroot contains all the POSIX functions and links into everything. Changes to libroot could cause a missing symbol error.

To avoid, you either have to 1) use same Haiku version that application was compiled on or 2) recompile any libraries giving symbol error on your current Haiku version.

Haiku ports are the ones bringing over the libraries to Haiku. Instructions here for pango:

Haiku-ports is better to give you help with libraries on Haiku.

learn to use Haikuporter which will make compiling libraries easier on Haiku. Downloads source, compiles and can even install libraries for you.

Sorry, I kniow this the wrong place to mention this, but I can’t seem to find the create account page in haikuports.

Basically, pango requires a new version of glib. GLib says no libintl.h support and stops when gettext support isn’t found. Assuming that gettext is in libintl, which I can find as a shared library, can I patch configure to skip this bit, and edit the makefile to include this library?

Only mailing lists for HaikuPorts. Sign onto the dev list which is meant for compiling libraries & programs.

you can install gettext if you want (use -l to get a list of installable packages).
installoptionalpackage -a gettext


  1. you can try ./configure --help to see if there is a switch to disable gettext support
  2. edit configure to not check for gettext and then change Makefile to remove linking to gettext library (-lintl) might not work. gettext likely rooted in source code for glib.

Cheers, that would be why I hadn’t heard of anyone else having the same problem :slight_smile:

Download latest it should help.

I tried to install it but it says “The requested package failed to install on ythis system. This may be a problem with the target package, please consult the package distributor”