Lenovo z580

I just bought this laptop: http://support.lenovo.com/us/en/products/laptops-and-netbooks/ideapad-z-series-laptops/ideapad-z580

I downloaded today’s nightly image and booted. I get the boot screen for about 5 seconds. Then I get a Panic: Can’t find boot partition. But I am booting from the CD.

Have a look, maybe there’s some info already, or something you can add, in these tickets.


I downloaded today’s nightly image


Boot Alpha4 ?


I looked at those tickets and I am not sure I have anything I can really add. Also, I don’t have access to Trac and can’t add comments anyway.

I downloaded rev49301

Try to boot from one of the USB2 ports (on the right side, while USB3 ports are on the left side, where the hdmi is as too) and not from the CD Drive.

Tried to boot from one of the usb2 ports, same problem… bummer. Now I don’t have any hardware that runs Haiku.

Hi DFergATL,

jump into the bios and switch “USB 3.0 Mode” to “Disabled”. You can find this option under “Config / USB” or something like that. Then please check under “Security” the following options. Switch “Secure Boot” to “Disabled”. Now check under “Startup” the option “UEFI/Legacy” and switch this to “Legacy only” or “Both”. This should be help.


OK Chaotic, here is what happened

Spent 45min in BIOS: There is no option to disable USB 3 anywhere in my BIOS, also I am unable to find any setting for “Secure Boot” the only option I have is to set a password for the BIOS and the HD, nothing about Secure Boot. UEFI/Legacy, the only option I have is to support Legacy, I can’t turn off UEFI.

In the end, I still can’t boot anymore. I will keep an eye out. But honestly my interest in Haiku is beginning to wear off, been here almost 12 years. I don’t think it will ever get done, and I am serious about that.

Boot Alpha4 ?


I will try that when I get home today and let you know.

Same thing happened on a HP Stream 11 and other recent HP models I tested earlier this year. From my experience, there’s not really anything to be done, but wait. Toggling ACPI, USB 3, Legacy support, Secure Boot, and other said options did nothing to solve the problem with some; with others, however, doing so worked and Haiku booted up. Try holding Shift and booting in Safe Mode or in VESA and see if maybe you have better luck. And you might, however, be able to burn an image onto a DVD, plug in an external USB DVD drive, and boot from that. I have honestly found that sometimes it’ll read off a DVD where a USB stick will fail.

If anything, you may be able to file a bug report, ticket, or submit the logs to the Haiku development team so said problems can be patched. Good luck with it all.

Tried A4, no luck.


I tried all the different safe mode setting I could. Anyway, looks like I am dead in the water as far as Haiku goes. I can’t log a ticket. Been trying to get my password for Trac fixed for 6mo. I finally gave up.