Lenovo ThinkBook 14-IIL does not boot from USB

I am trying to boot Haiku from an USB pendrive I created using balenaEtcher on a Lenovo ThinkBook 14-IIL. I have tried 3 pen drives already, and neither of them worked.

In the BIOS, I tried both Legacy mode and UEFI. In case of Legacy mode, I got a screen with a dash prompt in the upper left, but nothing else happens. If I switch to UEFI, I get a nice boot menu, but it doesn’t seem to find the boot volume for some reason:

Does anybody have an idea what could be the problem?


PS: the same ISO works nicely in VirtualBox, so the image seems to be fine.

1 Like

Try other USB port, or connect the usb disk via a USB2 hub or try to change the USB settings in your BIOS/firmware or write the Haiku image to your hard-disk via a different OS (warning, it is can cause data loss).


Try using a different tool other than balenaEtcher, something like win32diskimager, balenaEtcher sometimes triggers that error ‘boot volume is not valid’.

I have tried all the USB ports, and changed all the USB settings I could. On another Asus notebook, I could boot Haiku, so this is probably a problem, specific for this computer/type. So potentially, the phenomenon is not caused by balenaEtcher.

Does anybody have any experience with this Lenovo Thinkbook type?

1 Like

If you select the “Select boot volume” option does it list any options there?
It should list at least one option “Latest state”

Unfortunately not:

1 Like

Does your bios have some setting where you need to add drives to be seen by the uefi/secureboot/whatever ? Had one notebook here a couple days ago where this option was need for it to list a disk as bootable.

No, there is no such option in the BIOS. What I tried now is that I mounted the Beta 4 x86_64 ISO to a QEMU virtual machine on Fedora, as well as one of my pen drives, and tried to install Haiku from the virtual machine, following this tutorial: UEFI Booting Haiku | Haiku Project. Now I can’t even reach the Haiku Boot Loader.

1 Like

I don´t believe it should change things, but can you try recreating the usb drive with another program ? I would suggest rufus, just because it is what I use here.

I’ve already tried using dd in Fedora, the result is the same.

1 Like

It may be a UEFI problem, is there a Legacy boot option in yout BIOS?

Or maybe you are trying to use an x86 image on an x86_64 machine?

1 Like

Thanks for the suggestions! I mentioned in the original post: I have tried Legacy boot as well, then the boot process is stuck at a screen with a dash in the upper left corner. I wonder if I had to write some extra bootloader manually on the pen drive to make it bootable.

I have tried both x86 and x86_64 images, neither of them worked.

1 Like

Did you install 2 partitions to the UEFI version? I wrote a step-by-step guide on another post.

Something else to try in EFI mode - move the USB stick to be the first boot device in your BIOS settings - note selecting it from a boot menu is not the same, actually putting it to the top of the boot order works on my PC otherwise it won’t boot. TBH sounds like you have a different kind of issue to me, but probably worth trying it.

Thanks you all for the answers, I will try both (in fact I think I have already done something very similar to the one you suggested @SamuraiCrow).


I followed the exact steps you suggested. Until now I could boot up Haiku from an USB Stick in QEMU, at the moment it shows exatly the same picture as in my initial post on my physical hardware :frowning: