Learning more about Haiku and changing to Virtualbox

I used Haiku as my daily system so far on my laptop. I had to quit this now because there is no brightness adjustment for a laptop and working several hours a day with it leads to eye pain. I changed Haiku to the dark theme but most of the time I use a browser. And Webpositive and Otter lacks a darkmode, so I sometimes have to watch into brilliant white web sites. Long story short, I installed again NomadBSD (FreeBSD) on my laptop where everything works fine, including brightness adjustment.
I installed Haiku now in Virtualbox and I will use it daily as I did till now. The speed of my laptop is fast enough and Haiku runs very well.
The next point on my agenda is to learn C++ from https://www.haiku-os.org/development/ by DarkWyrm. I will do this on Haiku and, who knows, perhaps I understand more about Haiku itself. At least I will learn more about development in general.


Too bad going native didn’t work for you. I can relate, I worked for 5 years with a glaring 100% backlight in Haiku. Then the intel_extreme driver got a make-over, leaving me with a black screen, having to use VESA. Or so I thought…
Turns out, after waiting between 1 and 10 minutes, the display pops up - the veil is lifted, Haiku appears in soothing adjustable brightness. :clap:

1 Like

Now I am using an external monitor connected to my Thinkpad so no brightness problem. But I had your issue before when using laptop’s screen.

A not ideal solution (which I had found somewhere in these forums I think) but worked well for me was the following: could adjust brightness before Haiku boot, when system was just began running, through specific laptop’s keyboard keys. It was helping that I have a BIOS password. When the system stopped waiting for the password I was adjusting brightness. Don’t know if it works with all laptops but you may want to give it a try in the future :slight_smile:

1 Like

I have to use the Vesa driver. My laptop has a Optimus Intel/Nvidia card which is unsupported. The brightness is not adjustable.

This would really be a game changer but on my Asus Laptop it doesn’t work. I tried it but the FN-keys only work on supporting systems, not on boot.