Layla 3G


I tried Haiku with a Layla 3G audio interface. I know somebody made drivers for Echo Audio cards including the 3G one which is in Haiku.

Audio output is working but no audio recording. Everything appears to show up correctly in the UI. I can’t record in SoundRecorder. It appears to connect in Cortex but transport doesn’t roll.

Also, no MIDI. I have tried Sequitur and can choose MIDI in and out but it doesn’t work. Is there actually any way to presently get any MIDI hardware fully working in Haiku?

Another problem is that when the Layla is attached it causes a kernel panic when I also have a net connection. The crash happens when I hit the desktop. Seems odd. I don’t understand why there should be any relationship here.

My motherboard is an Abit IC7-G with PIV 3.0 GHz HT CPU.

Hope that helps ! :wink:

I think he has already installed these drivers and has audio working for playback. Not got it to record anything using sound recorder though and he can’t seem to get midi working.

for midi playback at least, you need to install a soundfont.

The Kernel panic when attached with networking will be an IRQ routing problem, I think this is next on the dev’s list of things to do.