Just when I thought things were looking good

I thought I had a working OS until about boot number 20(approx) I had kept a rough count because I’ve had this happen on a previous install…Boot fails but a half sized screen arrives saying 'Panic Assert failed THREAD 98 “SSHD” welcome to debug land etc:(

I have no idea what caused this because I had not made any changes…any suggestions?

I haven’t a clue what could cause this, but try to reproduce the problem in a controlled setting if you can.
Install a fresh copy of the OS (preferably Alpha 4.1) and repeatedly reboot it without doing anything with the install whatsoever (no software installation, preference adjustment etc.). Does it still fail at boot #20? Does it need to be coldbooted for this to happen, or are warmboots sufficient?

Have you tried booting your existing broken installation with various safe mode options? It might be that something has got messed up in /boot/home/config/settings which will be bypassed in safe mode.

I did see something with my installation that reminds me of this. After the first few boots, the wireless network card disappeared and I needed to type ifconfig up /dev/net/atheroswifi/0 so something must have got messed up. The fact that yours fails with something related to sshd also points in the direction of the network stack or network drivers, it would be useful to get to the bottom of this…

Did you set up and use the network card?

Panic Assert failed THREAD 98 “SSHD”

This referrs to the ssh daemon. Did you enable it?

SSH stands for Secure Shell, the SSHD is a service that needs to be running to allow others to ssh in over the network and have access to your haiku machine as if they were sitting in front of it and running the Terminal app. This service is not enabled by default. one must edit a file: /boot/common/settings/network/services

and un comment this section:
service ssh {
launch /boot/common/bin/sshd -D

as well as adding a user by running useradd from a Terminal.

If you are confused about the reference, it is a good bet that you did not enable the SSHD daemon.

Make sure that /boot/common/settings/network/services has not been corrupted. you should be able to boot in safe mode to do this, unless there are other problems as well.

Sshd seems to be enabled by default for me, this is a relatively fresh Alpha 4.1 install. I noticed that in ProcessController before. It seemed a little strange that it would be enabled on a desktop system. Luckily I’m behind a firewall…

This is a wired connection and it basically worked OTB.

This was essentially a ‘controlled’ setting but I must confess to a feeling of security after about 15-16 boots so my count could be inaccurate.

This is Alpha 4.1…problem persists cold or warm.


…not me, no I wouldn’t install this intentionally! yep…confused about the reference.

I have been using bootloader from a CD but Alpha4.1 is installed to HD

I have filed a ticket regarding the sshd daemon … https://dev.haiku-os.org/ticket/9459 . This service should not be running on a default install. If you repair the file and comment out the section re ssh does it fix your boot problem?

When I boot in safe mode I am allowed to get as far as /services…then I get the error message ‘unsupported format’.

I will try a re-install and if I can, immediately comment out the section you suggest…or even on the live cd before the install.

Thanks for your help!

In the end, I just did a ‘move to trash’ on /services…and all is back to working mode again!

Any idea what happened to the file? If it happens again, could you zip it up and post it somewhere? I wonder if there could be filesystem corruption occuring. I hope not, but this would be such a dangerous situation that it really ought to be looked into. Have you run any kind of filesystem checks?

Due to the response to my ticket, I have added a program to control the network services …


This makes it easy to disable ssh for those who don’t want to run unneeded services on their Haiku box.

I put the file in trash, booted in a few times and since all appeared OK I recovered the services file and ‘commented-out’ the offending bits and all is back to where it was when I started…I guess.

I hope it stays solid!

I haven’t run any file system checks but if you have any requests I am happy to do what I can.

I’m wondering if this ticket is related:

plumtreed - if you’ve backed up all your data and are in a position to potentially reinstall if things go wrong, then you could try running checkfs. Perhaps you should file a ticket about this specific problem, linking to this thread and the other ticket above?