Just a quick whinge :Haiku freezing on AA1

Hi, I tried Haiku on my Acer Aspire One netbook back in the alpha days, even happily dual-booting with Linux, (possibly even triple-booting ok via grub from internal 8GB SSD) and it seemed rock-solid. I used it enough to really like it, but after a hiatus of a few years I’ve fresher versions of Haiku to be unstable, tending to freeze a lot, any idea why that would be?

Is this on the beta2 or Nightly branch?

I’m sorry, I’ve just wiped it from my SSD boot drive and I don’t have a record. I think it was probably an anyboot nightly, although I think I’ve had the same instability with both nightlies and the Betas. I did a software update and it froze during that, then finished the update the second time I tried, but upon shutdown it required a long press on the power button, which it didn’t used to.
I’ve installed void-linux on it today and then had boot volume magic number problems reported, so had to run fsck on it so perhaps that was the cause of my Haiku problems.
If so, I apologise for suspecting the fault perhaps lay with Haiku. I imagine I might find void/MATE too slow for the netbook so I may try again with Haiku quite soon, after making sure my SSD is ok. Thanks for your reply.

fsck is a file system specific command on linux, its unlikely to be related to the issue (unless the issue is that your ssd is actually broken)

QUOTE[unless the issue is that your ssd is actually broken]…well I thought perhaps the SSD had suffered some bitrot

Yeah the Nightly branch is more unstable than the stable/beta2 branch, but the advantage is it also has the latest features, fixes, etc. like if there’s a new graphics patch or something so that’s the first one I’d try to see if there’s a fix

I tested Haiku on an Aspire netbook before… and (far as I know anyways) they have trouble restarting, so maybe try to turn off ACPI in the (safe) boot options before Haiku starts up (and also do a restart instead of a shut down, where it usually hangs)

haiku-acpi

With the filesystems, I doubt fsck (filesystem check) messed it up, so I’d guess if something on the disk went corrupt (and the SSD is ok) that it’s probably something that went wrong when formatting everything; considering Haiku is still in beta (although it usually handles formatting ok), to be safe since you mentioned booting multiple systems on it, I’d format everything with parted/gparted on a Linux distro then make the BeFS stuff in Haiku

@apgreimann
Thanks for your detailed and helpful answer. The fsck came after I deleted my old Haiku and installed void-linux MATE, and I had forgotten that the SSD had two Linux distros on as well as Haiku.
The Samsung 8GB SSD has not done much in ten years and I’ve found them ok, for light occasional use.
I deleted void-linux MATE yesterday and installed the latest Haiku nightly, formatted the whole SSD to BeOS, etc. I’ve swapped distros and Haiku quite a lot on the two AA1s that I have and installing Haiku is always easy and quick.
Post-install did Software Update ok, then …not so good: no app menu top-right, desktop icons showed empty when opened, no right-click menu on the desktop, only a vertical line.
I forced shutdown and installed the Beta and then ran Software Update and all seemed ok, except I couldn’t get my old VGA 1024x768 monitor to work on that resolution when selected in Screen, only working on 1024x600 (It works ok on Linux) and the inability to cleanly shutdown. I’m old and my memory is not great, but I think that that used to work fine on the netty a few years ago. Shame it doesn’t support two monitors with different resolutions, as my eyes aren’t so happy with 1024x600 on an 8.9" screen any more.
I’m probably flogging a dead horse trying to find a use for my netbooks, maybe I should give Haiku a better chance by installing on my old Santa Rosa MacBook Pro, which would probably be a challenge. Thanks again.