Is wpa_supplicant broken in latest nightlies?

I’ve been using Haiku on a EeePC 901 for quite some time and was delighted that I was able to get a WPA2-encoded Wifi connection on the ralink2860 card since last October when wpa_supplicant became available.

However, I update the version of Haiku with a new nightly now and again. Over the last month or so, I have not been able to get a wifi connection using wpa_supplicant on a new nightly.
The latest one I’ve tried is r43883.
Certainly the card is working (it works fine in Ubuntu in a different partition on the same machine), is found and identified by ifconfig and the available wireless networks are being picked up.
However, neither using the command line nor the GUI results in a wifi connection.
It seems wpa_supplicant does not remember the network passcode as, despite checking the Store this Configuration box, the Password space comes up empty every time.
I even included the passcode in the Network section of the /boot/common/settings/network/interface file to no avail.

Has anybody else had a similar experience?

Have any of you filed a bug in Tracker?[/quote]

No, I haven’t as I’m not sure my problem is the same as described by Cristof and you.

I have an ethernet connection to my 901 and, if I unplug the cable, I get that “Network Status: Loop Disconnected” popup.
However, when I try to connect wirelessly, no popup appears.
The fact that you and Cristof get this suggests that perhaps you were wirelessly connected for a few seconds before disconnection.

Also, because nobody has confirmed my experience in almost a week now, it seems that my problem may be unique to my computer.
I’ll try a few more recent nightlies.

I also can’t get WPA2 wireless to work on my eeepc 901, using a fairly recent build. A few seconds after choosing a network and entering the password, a network status window pops up reading something like “loop: connection failed”.

I have never had wireless running, though. Glad to hear that there was at least a revision where it worked :slight_smile:

That’s interesting if unfortunate.
If you try to connect to the same wifi network again, does the popup box “remember” your password?
Mine doesn’t which suggests this is a wpa_supplicant problem.

What I find strange is that even when I downloaded an old nightly (r43718) which fully allowed wifi WPA2 connections on this same machine, this time it didn’t work.

I can confirm the “loop failed” message mentioned by Cristof still happens in rev43901.

Have any of you filed a bug in Tracker?

Hi paulfxh!

To answer your question, on hrev43886, the revision I have installed on my eepc 901, the popup box for connecting to a wifi network does not remember the password. However, as mentioned before, it is unable to connect at all. Maybe the password is stored only after a successful connection?


Hi again!

The main problem I am having seems to be driver related:

I have tried hrev43719 as well as hrev43951 and they both crash, as described in the ticket.


Using hrev44007 on EeePC901 (ralink2860 wifi card), wifi works perfectly once again.
However, it only seems to work after I “clean” installed Haiku.
When I replaced only the /system directory from hrev44007 without initializing the Haiku partition I could get neither wifi nor an ethernet connection.

Thank you for the tip, After a clean install it is working for me, too :slight_smile:
But there are still hiccups:

  • The WIFI network password is not saved (in fact, not even the “remember password” checkbox is shown),
  • Frequently it doesn’t connect properly. It usually takes a few tries.
  • Status messages keep popping up every minute or so (“loop configuring” / “loop ready”).
    Do similar problems appear on your machine?

No, the network password is not saved. This has always been the case.
No, I never have a problem establishing a wifi connection. Connects first time, every time.
Yes, I get those status messages but not every minute. It might be once ot twice an hour.

To overcome the failure to remember the network password, I use a small script with the following

#! /bin/bash
sleep 5
ifconfig /dev/net/ralink2860/0 join wifi_network_name network_password

I’ve put this in /boot/home/config/boot/UserBootscript so that wifi starts at boot without having to enter the network password.