Is There Something I Can Do About This?

I have an MSI barebones I put together and have been having fun with Haiku Alpha 2. I really love it. I’m able to get ethernet and don’t have a wireless card, so that’s a moot point. I can get “fail-safe” video, but cannot get sound. So far I’ve just been using the Live CD. I’d like to install Haiku but thought I’d first ask here about my graphics and sound - if there’s anything I might try or install that would work. I have an Intel integrated board and I had hoped, just being from the recent past, it might be fully supported. In Preferences>Devices, the video and sound components are recognized yet here is what it says (the important parts, I mean):

Graphics: Intel Corp. 82945G/GZ Integrated Graphics Controller
Device paths - not implemented
Driver - not implemented

Sound: Intel Corp. N10/ICH 7 Family High Definition Audio Controller
Device Paths - not implemented
Driver - not implemented

Does this mean this hardware is simply not supported? Or does it mean there’s something I can do to “implement” it?

Thank you very much.

1 Like

You could always try the Open Sound System for Haiku; OSS is more of a backup driver than anything, so it doesn’t have official support.

No, that just means that Devices isn’t yet capable of retrieving that information.
You get more accurate info from using listdev in Terminal. I thougt the intel 945 was supported, as well as the HDA ICH 7… Maybe there are just missing device IDs.


Indeed it does mean that getting that information is not implemented. I will have time again next month to work on the Devices app, this has been confusing for quite a few people.

There is a graphics driver for 82945G/GZ in Haiku. It now works for me on lcd monitor since this bug was fixed:

You will need Haiku r36941 or newer (nightly image). Try to get nightly close to r36941 since some other changes going on lately which may have caused one or two bugs in Haiku.

To actually see what drivers are loading in Haiku you should do following:

ls /dev/audio/hmulti

Graphics (you’ll always have vesa listed + any accelerated driver):
ls /dev/graphics

ls /dev/net

listdev only shows the hardware installed in your system (ie: hardware description) not the drivers that are loaded for it. listdev output for your graphics and audio help in searching for any drivers that should support your hardware by providing vendor and device ids with name and description.

if you want to see loaded drivers you have to go in KDL ( press ALT SYSREQ D )
then, type the following command :
modules|grep kernel|grep driver

to leave KDL, type:

I want to thank all of you for your help! Here is what has happened:

I did download r36941. It was recommended to download gcc2, so I did. I installed and, yes, that graphics driver is in there. Great graphics! No sound though - rats.

I used the terminal to download Webpositive and other applications but learned that you can’t get Webpositive if you’re using the gcc2 version. I did download Bezilla so I’d have something. I also downloaded Open Sound System from the terminal. After installing it, it fouled up the whole media preference…perhaps because I was using a nightly build.

That having happened, I decided to download that same nightly build except this time get the gcc4 version. This went very well! Same great graphics and I was able to download Webpositive. This build seems stable…so far, so I’m sticking with it for now.

As far as sound is concerned, I don’t know. I looked in hmulti and here is what’s in there:


I guess nothing very Intel-sounding,lol. If I could get sound I’d be on easy street.

Thanks for your help!

WebPositive is gcc4 compiled because of libwebcore. WebPositive will still work with gcc2hybrid too. You should always get hybrid versions to to use the most applications out there. gcc4 is better for all the newer game ports coming out on haikuware.

You actually might want newer nightly because I noticed that Ingo was changing stuff in Haiku and see that some of his changes did not go through until after r36941. Ingo (bonefish) started important changes with:

And you miss fixes like one below when using r36941:

Looking at the changes I would say better to go with nightly of 37001 to 37016. 37011-37016 maybe somewhat better choices but these are too new to know for sure yet. It takes couple of days to see what other changes and bugs follow. I am now using r37001 and seems to be working very well for me. ie: (for fun) I compiled WebPositive without any issues, surfed the net, ran a few programs, etc.

You looked in wrong place for hmulti. You can only see that folder and list contents by using terminal and not tracker.

Start terminal and type in ls /dev/audio/hmulti. If that folder is empty then no audio driver loaded for you. From terminal, type listdev and provide the output for your audio card here. Using listdev lets us match what driver should work with your hardware by giving more precise device information.

You can also check for audio driver with Preferences->Media->Audio Settings, but looking under dev folders says for sure what drivers have loaded in Haiku for you. You still have OpenSound to try if there is no other loaded audio driver.

Thank you! I’ll try that newer build.

Also, after I posted, I realized the mistake I made, looking in the hmulti folder. By looking around I also noticed that auich are the Intel drivers.

Then, I did realize I was supposed to be using the terminal for that, I did, and hda was the only one that came up.

LOL, also, I found that, to use OpenSound, you have to remove or disable the hda driver first. Whoops! No wonder my whole media pref was fouled up after installing it.

Well, I have more fun ahead of me (it really is fun).

Thanks again!

Ok, no worries, mistakes happen. :slight_smile:

So, it seems hda driver is loading for you but not working. You can file bug ticket (after registering) with your syslog (/boot/common/var/log/syslog) over here:
That way the developer can be made aware of the problem and fix it at some point.

Yes, conflict between OpenSound and native Haiku drivers. So, if native driver is loading for you, then you have to disable it somehow (usually remove it).

Happy to hear things are now working out for you. Have lots of fun. Bye,

How to disable hda drivers in favour of open sound system