Is it possible to copy over older drivers from previous nightlies that worked to newer nightlies that have a broken driver?


#1

Would it be possible to port an older driver from older nightlies, I’ve tried using the hrev49662 driver from /boot/system/add-ons/kernel/drivers/intel_extreme and copying it over to the hard driver with hrev52187 x86_gcc2 into the directory /boot/home/config/non-packages/add-ons/kernel/drivers/bin/intel_extreme, I blacklisted the original intel_extreme driver as well to see if Haiku would find where that older driver was and it would use that as the default. I seemed to be wrong since it defaulted to use the VESA fallback driver with the resolution of 1024x576.

Is it possible to get an older driver onto newer Haiku nightlies through another method?

If there is, let me know, because I’d be glad to use it.


#2

There were changes made to the Kernel in hrev52187 that make this not work.

I did that for a problem with prior hrevs by adding the driver to

/boot/home/config/non-packaged/add-ons/kernel/drivers/bin

and linking to it from

/boot/home/config/non-packaged/add-ons/kernel/drivers/dev/graphics

but this no longer works for me.

If you are getting the intel_extreme: attempting to clone non-user-cloneable kernel area! KDL see https://dev.haiku-os.org/ticket/14333 This was fixed in hrev52197.


#3

The newer hrev you posted doesn’t work sadly.


#4

I don’t know if it is possible to copy over a driver from an old hrev, but I would recommend filing a bug instead. You’d be surprised how fast bugs get fixed most of the time, especially if the driver worked previously.


#5

I did, it’s still open.


#6

Unfortunately in the case of intel_extreme, there was a large refactoring with lots of changes at once which broke a lot of old devices (but made it work on some newer ones). I fixed what I could by testing the hardware I own (except one machine I still have to figure out, but it starts working when I enable serial debug on it…).

As a result, it is hard to know which part of the large changes is a problem, and we don’t want to throw away the new architecture (it is a lot cleaner) to revert to the old driver which was less clean code.

Please link to your ticket, I may have a look to see if I can spot something.


#7

Here is the ticket, I added a recent syslog from the most recent hrev52211 a few minutes ago, https://dev.haiku-os.org/ticket/14276


#8

Ah, alright, didn‘t know that. I guess I was lucky withmy 2 bug reports, the bugs both got fixed in about a day.


#9

That is my problem. I use an older driver on hrev 52165 and am stuck there due to the recent kernel changes until this one ticket is fixed.