Is FuseSMB supposed to work?

Is FuseSMB supposed to work? I’ve downloaded and installed it, I can see the “SMB Network” mount on my desktop, but it never finds any servers.

Also, does anyone know if it generates logs?

It supports just SMBv2 and not the newer version. It is a limitation of the current samba port, but a new samba 4 port is already in work in progress state. See here:

Till the porting finishes there is a workaround: tell to your server to use SMBv2 for sharing.


Thank you! Shall try that - cheers!

I guess you already checked the Network prefs and did a “Scan now” there?

Of course - nothing at all changed. Nothing in /var/log/syslog… we really need some kind of logging strategy :slight_smile:

If you want some output run the program using the terminal. You can store the output into a text file:

/Path/to/Appname > /boot/home/Desktop/output. txt

I got this, thank you, it’s just annoying that there’s no standard logging for daemons… So the only way you can debug output from one of those is to kill it using the Haiku commands and then manually start it piping the output to a text file… not particularly user friendly.

It’s actually only SMB version 1 (i.e. pretty much CIFS). Not a problem if your server is Samba or Win, but e.g. recent versions of OS X don’t seem to support that version anymore.

FuseSMB-Haiku has a number of bugs and problems. I’ve recently started work on a successor to it (won’t be using fusesmb code anymore) which directly uses the FS add-on API, without FUSE. Can’t say when it’s done – but it should fix most problems related to share discovery and performance. (However, for the time being, it will still be limited to SMB 1).

There is a hacky workaround that worked for me. Create a file: ~/config/settings/fusesmb/fusesmb.cache where the contents of each line are:


Where <workgroup> is the workgroup name, <server> the server name and <share> the name of the shared folder on the server.

My samba server is a Linux box, but no matter what I set the protocol version to I couldn’t get haiku to see my shares, and the above made them appear right away. But YMMV.

1 Like

Hi! Is it possible to provide a user and password using the fusesmb.cache?

Well I got egged into taking this down last time I posted it, but I think if you want to access password protected shares you need to manually create the config file and mount and unmount manually, because otherwise the preflet will keep overwriting the config file. Edit ~/config/settings/fusesmb/fusesmb.conf with an entry for your share (using my share as an example):

timeout = 60
showhiddenshares = true
interval = 15



(I don’t know if both the share and server entries are needed)

Create the directory for the mount point with e.g. mkdir /SMB\ Network and mount with mount -t userlandfs -p fusesmb /SMB\ Network , and cross your fingers. You can unmount with unmount /SMB\ Network.

I know this is hacky but as far as I know there is no alternative at present. It still probably doesn’t work in many cases but it might be worth a try.