Intel HD Graphics 4600 - Beta3 vs alpha 4.1

I have a Intel HD 4600 graphic card that make some bad things with my screen. I can not run fullscreen on my beta3, beause the screen is bigger as my seeable Desktop.

Yesterday i start past long time Discover Haiku vom TTS and see that on alpha 4.1 are all correct displayed.

Can i take the driver of my graphic card from alpha 4.1 to make my graphic card more useable on beta 3? How can a find and use it?

1 Like

A quick note that some Intel graphics bugs are fixed after beta3 - a nightly might actually display properly

Right, i will check this.

I update my beta 3 today and realy this issue sounds like solved. I have higher resolutions and it looks great.


Can you set multiple resolutions ok? And what does screenprefs tell you (driver and screen info)?

Alpha probably ran with vesa, while you now work with the driver as I updated it. Beta3 already ran with the driver I expect, but it wasn’t developed enough yet back then…

I will take a look tomorrow

I have this graphics card here:
For more than 18 months, the nightly ones have been running wonderfully under Haiku 32bit + Haiku 64bit.
Since June 60th, 2021 only under 64bit, unfortunately!
Both haiku versions are updated almost daily.

Update (on Windows laptop):
Under Haiku 64bit I can select different resolutions.
Haiku 32 bit - screen shot

@rudolfc no i can not set other resolutions as 1920x1200. If i change to 1024x768 or other sizes, i get a splc screen with half size use.

But i get a higher resolution on haiku as at windows as default.


1 Like

Ok, so it’s not yet fully ok for you. Can you open a ticket with this info and also upload a syslog to it? I can have a closer look then.

Thank you! :slight_smile:

So your graphics work ok ? With the driver or vesa?
On 32 bit you have a different problem, not graphics related from the looks of it

Nice device btw! Love it :slight_smile:

Over here on my Skylake system the boot fails on 32 bit if I leave power management enabled, I have that disabled in the kernel settings file I believe. But your error is something else indeed I think.

Thank you, I love this mini pc a lot too.
So I not only have enough power on the desk, but also on the go.
I take it with me and connect it to a TV or projector.
32bit worked up to and including the 26th!!! June 2021 just as perfect as 64bit Haiku - after that never again!
Updates almost every day, again and again (unsuccessful) boot attempts with current nightly USB!

Oh yes:
A Rii i4 Mini Bluetooth 4.0 and 2.4GHz keyboard with touchpad
works great with Haiku (32bit to 30 Jun 2021 + 64bit) on this Mini PC Zotac ZBOX IQ 01.
Tested in 2.4GHz mode, very high-quality workmanship, comfortable keyboard, touchpad too! Good for mobility!
Combination (mini PC + mini keyboard) possibly as a media center on the TV (under Windows with OpenELEC, PLEX and?). However, I have not tested it.

Did you create a ticket for this already? If not please do so. I would love to see a syslog for instance with and without the tv or projector, I’m curious what happens at least :wink:

1 Like

Done: #17603 (Intel HD Graphic 4600 (After update new Driver 2022)) – Haiku (

1 Like

Unfortunately, I can’t really remember exactly when it was, but about 18 months ago I was able to get the most out of the ZBOX iQ01 with a nightly haiku with Haiku 32bit + Haiku 64bit!
Only these two have been installed since then. The connected hp monitor (1600 x 900) was also used directly in its native resolution = no settings necessary!
For a long time I always got the message: “Out of range” and here in the forum the monitor was suspected and not Haiku!
So, if 32bit + 64bit BOTH optimally used the ZBOX from a certain nightly time - over a period of approx. 12 months…
but then (from 06.2021) to this day Haiku 32bit no longer, what is the reason? Surely not on the computer if Haiku 64bit continues to use the hardware optimally (except for one night at some point)?

There’s just one way to find out. If you create a ticket and upload the info and a syslog, and you are willing to do some testing, there is a chance we can solve this.

I am focussed on the extreme driver still, so I hopefully am able to come up with more details and possibly a fix :grin:


Yesterday I was out of the house, now here again!
Haiku 32bit + 64bit updated.
Haiku 64bit started, screen resolution 640 x 300 (?) (native 1600 x 900) selected: … Outside the range = nothing works anymore - like years ago!
Haiku 64bit rebooted with yesterday’s nightly +shift +++ resolution 1600 x 900 x 32bit selected, reboot:
Symbols are displayed in 640 x 300, at the end: … Outside the range = nothing works anymore.
Where does the 640 x 300 resolution come from? Is it ‘stored’ or initialized in the monitor?

A lot of questions which can best be answered via a ticket with syslog etc. Without that data I need to start guessing which I think is not a good way of working :wink:


Ticket, Syslog are (unfortunately) not familiar to me…

Reporting bugs should give the required guidance here