Installing/using wifi hardware, using terminal?

My ageing Dell Laptop is now ‘back to life’ after successfully installing Haiku. However I can not access the onboard wireless card. Refering to the manual, the first step would be, in Terminal [right mouse click on desktop, open terminal, welcome to the haiku shell, cd to get to the root?] to ‘run’ the script: , terminal comes back with the message ‘command not found’. What have I done wrong? Now I know… it should be: ! which worked [of course] in my defence an S after firmware is like an s after sheep, firmware is a collective word not needing an s. Ok my mistake…


To avoid typos like this, use tab-completion. Type “install” and press the tab key twice to see all available commands starting with “install”. Continue with “-wi”, hit tab, and it’s completed to “”.

Thanks for this, uo to now Ive still not managed to achieve a wireless connection [dispite the apparent working systems] which is dissapointing. Not very enthusiastic about continually having to use code to get anything to work…

It very much depends on your hardware. What chipset do you have?

I’m using the iprowifi4965 driver in my main notebook and had to use a “ifconfig” commandline in a boot script to reliably connect wirelessly. I just installed Haiku on an old subnote Samsung NC10 that’s using atheroswifi and that works like a charm by choosing the network from the replicant in the Deskbar…

Chipset? I spent days and days rehashing the config.sys and autoexec.bat in the dim and distant past when all we had was DOS and 640kb memory, since then such things are no longer interesting to me, I have a Dell inspiron laptop and that’s it. If I have to become a system addict to get it to run then I give up and it goes in the trash. As I say having to use code to get things to work is fine if you have nothing else to do. When this laptop had XP on it everything worked OK without a line of code. I’ll give your suggestion a go [and let you know] another day…

Haiku is a alpha-state OS maintained by a few hobbyists who are (rarely) paid. You can’t really compare this to Microsoft Windows.

I share your frustration (my wireless card in my old Dell won’t even work without dropping the connection every few minutes) but you do need to be patient when it comes to hardware support.

Maybe there are a past version withouth the bug

Just to point out. As the Humdinger said, some chipsets do not work reliably in n-mode, so you may either change your router/AP settings to transmit only in bg-mixed/b/g mode or manually disable the high throughput by writing “ifconfig /dev/net/%your_chipset%/0 -ht” in the terminal. Refer to the “Avoiding connection loss” section of the docs here:
I should say that all my wireless cards on fujitsu laptops (2007-2012 models) are working fine.

To all who are concerned enough to reply to my thread, thank you for all your input. The fact that there are so many variables to contend with on the hardware front makes life difficult. I appreciate the Haiku OS base situation, I simply do not understand the difficulties involved, expecting all manufacturers drivers to work on all systems, which is not the case it would appear. Thinking back I had problems with the wireless connection on the mach. in the past so maybe it’s a dead horse anyway. I’ll give a couple of your suggestions a whirl and get back if there is anything positive to report. Lets consider this closed for the moment.

Welcome to the Haiku shell.

~> listdev

device Network controller [2|80|0]
vendor 8086: Intel Corporation
device 088e: Centrino Advanced-N 6235

Copyright © 2010-2012 Haiku, Inc.

Distributed under the terms of the MIT License.


Matt Madia,


Provide a mechanism for end-users to install various firmwares for wireless

network cards in a manner that complies with their individual licenses.

Supported chipsets:

Intel ipw2100

Intel ipw2200/2225/2915

Broadcom 43xx

Marvell 88W8335