Installing to HD

I am having an issue installing to HD. I do the install, everything goes fine. But, the system doesn’t boot. Basically it doesn’t see a bootable partition on the drive. I have tried a number of different combinations of things when creating the Partition. I just want Haiku to take over the entire drive. I found these directions…

They don’t exactly fit what I am doing… but… anyway.

I don’t have a problem when installing to a VM. Only when I try to install on real hardware.

I would like to try to see if I can boot the HD from the USB. What is the key combo to get into the boot options?

I would kill right now for an option of “Erase Entire Disk” and install Haiku. Honestly, I spent hours trying to get this to work…

Have you checked active partition?

Erasing whole disk is not needed, zeroing first few KB is enougth.

Any recommendations on the tool to use to zero out the first few kb of an SSD? I’ll check the partition type, but I am pretty sure it is set to active.

Open Terminal, type dd bs=1M if=/dev/zero of=, drag and drop target disk from DriveSetup, hit Enter, wait few seconds and press Ctrl+C.

On my Haiku machine I first formatted the whole hard disk - raw, no partitions at all - in the BeFileSystem, as I wanted to take over Haiku the whole drive, too. I had no trouble installing the OS and booting it after that.
As for the boot option sequence, it’s in the BIOS, meaning you have to press one of the Function keys at startup (different ones for each computer type). As the computer tends to regard thumb drives as a kind of additional hard disk (you can actually install an OS on a thumb drive and plug it in as desired), not as removable media, “USB drive” will usually be somewhere lower down in the boot sequence. Push it up above “HDD”, and the computer should boot from USB.


That isn’t what I’m talking about. I mean the GRUP menu. It used to be “space bar” I think to get into the Grub menu. I think it has changed but I don’t know what it is.

Thanks, I give that a shot. I take it this can be done from the live USB desktop.

The problem is some BIOS are not happy with that and really want a partition table. So we are not recommending this method in the documentation. If it works for you, all is well however :slight_smile:

I have tried on 3 different computers, 2 desktop and 1 laptop. In each case the USB will boot and Haiku appears to work fine. I do the install, following the directions I listed previously in this thread. I also found these:

  • Create an intel partition table
  • Create a single partition that fills the whole drive
  • Format that partition ( not the whole disk )

In each case I end up with an unbootable system. I have tried multiple times on each system. I even tried formatting the entire disk just to see if it would work. No luck. 1 system ok, 2 systems… hmmm, 3 and I am going to just move on as I do not feel that it is me misunderstanding how to install and OS. It’s the OS that just isn’t doing something it should. I will try again when Beta 3 comes out.

I only have an old Samsung NC10 netbook that I can nuke and start a Haiku installation from scratch. I had a Bootmanager boot menu from an old Haiku+Linux install on its disk, so I did a “writembr” first to get rid of it.

Then I did it how you described above (made sure the “Active partition” checkbox at point 2 was ticked) and it just worked. Just FWIW…

If you replaced all other parts of the equation, the problem must be in your install procedure. From the one you listed I would guess at not marking the partition as active.

I agree that this process is still more complicated than it should, maybe we will have time to add the “I don’t care just wipe the whole disk and do the right thing” mode for beta3 or later. For now you have to follow the steps very carefully as each of them is important.

1 Like

I really, really did mark the partition as active. If I try to use the USB to boot and get to the grub menu. It will list the HD partition. but says it is invalid. After I boot I can mount my partition and use it, even though I can’t boot from it. The live USB shows Haiku is really shaping up. Good luck with the release guys. I will probably just play around with it in VMWare for now.

When you say grub menu, do you really mean grub or Haiku bootmanager?
Because if you have no other system on these computer there’s no reason to have grub which is a linux thing.
To get rid of it, use writembr as humdinger mentioned (master boot record isn’t initialised by format because on disk it’s before partitions). Having Haiku bootmanager installed can also help to enter boot menu. (you can enter it with space bar or shift)
If you still have a linux partition on another disk and really use grub then make sure that you’re using the right options in grub configuration.
If your system uses UEFI to boot, then it is completely different. The bootloader is not written to the mbr but there’s a file doing more or less the same thing in BOOT folder of EFI partition.

I am men the Haiku Boot Menu… sorry for the confusion. I think I will try turning off legacy boot and try using just UEFI.