Installer not working

New user here. I tried out Haiku maybe 5 years ago and stopped. I want to try again. Problem is that I cannot get the installer to work. I get the Haiku screen but it always stops on the 4th icon from the left. I am not sure if that icon is hard drive or something else. I have tried different options with bios but no luck. What am I missing? My brain? Help please.

Hi and welcome, have you tried safe boot options?
take a look on the userguide

1 Like

Yes I have. Tried different options in bios as well No luck yet. As far as the options in safe mode, I just have to try different combinations since I am not sure what they do. In any event it still stops on the 4th icon, hard drive.

Also, I get the error message PANIC: did not find any boot partitions. The only partitions on the hard drive currently are for Linux.

That’s the error I would get if I tried to boot on modern hardware (UEFI) without turning on Legacy Boot and enabling CSM in the BIOS (or whatever we call it these days).

If you have those options, try enabling them.

I have them enabled. There is an option for both Legacy and UEFI and tried that as well. I am still working on this problem, Thanks.

Nothing I have done so far has made any difference. I even tried a shot in the dark by updating BIOS (Nov 22, 2014). I do not know where else to other than trying on a different laptop - I have 3.


Use the nightly build and also give a try using a usb 2.0 hub between tour usb key and your computer.
Then try all the safe modes you did before.
I am not sure it will help but I did that before on another computer.

try using a usb2 port on your computer

Did that. I have used 2 laptops. Same problem. I used one external cd and one internal cd drive with no luck. Tried booting from a usb stick, more than one port.

Someone else suggested a nightly version. Will try that shortly. I hate being defeated. I will persist. And to all those who have responded, that you. Help is always appreciated.

Bye for now. More suggestions welcome.

I had success with nightly image 53572. Now the fun begins.

1 Like

glad see you success here… maybe you can report your hardware specification … and maybe some little detail… surely will help others

I finally got Haiku installed and running on my Levovo T540P.

Let the fun time begin with learning curve.

1 Like

Haiku will fly on a T540P. Apart from the “clunkpad” they are great machines, and a mouse makes the clunkpad redundant.

I find that Haiku is quite fast enough on a T61P, but will try it on my T540P one of these days.

Good luck, and remember that Haiku uses Ctrl in a different way if you are coming from Windows or Linux. if that causes problems you can change to the Windows method by doing the following:

Press the leaf icon, top right.
Select Preferences
Select Keymap
Press the button marked “Switch shortcut keys to Windows/Linux mode”.

Good luck.