Installed last HAIKU beta on USB stick which does not boot itself


#1

Goodmorning all, I’ve just flashed an USB stick with HAIKU installer to install the system on another USB stick. The installation went well to the end, and I’m then ready to boot from the HAIKU newly installed. But selecting the usb stick from the boot menu, a line in the blank screen advise no bootable system present on this volume.
And if I connect the flashed installation USB stick as well, I can boot from there, manage the bootloader going to boot the installed HAIKU on the other USB, and it just loads from there! So it seems no boot loader has been installed on the target stick, while HAIKU is there full working if its booting is recalled from the installation media bootloader. Does anyone know how to correctly install on a USB stick with self booting capacity? I’m anyway using the system loaded the way I described, and find it very performant, quick and responsive although it runs in an USB2 stick!
Thank you


#2

There is a write bootsector option in the menu of the installer that you may need to use on the target USB device.


#3

There might be a problem or some changes with the latest builds, I am also having a problems booting from USB on a Macbook Air. Right now it is crashing at the boot drive but yesterday it wasn’t even getting there, it was freezing before the kernel load. Unfortunately pressing shift to bring the boot loader options is not working either even using an external keyboard.


#4

if you just put Haiku on a USB stick without using the installer but using DD or Etcher… does that work?


#5

thank you cb88, I did not see the option. More exactyi, I wanted the USB volume booting in legacy mode as I’m trying to boot on a sistem which is originally UEFI but setted in legacy mode and with secure boot disabled . The thing is that some other USB with an OS boot themselves in legacy(MBR) , while others in EFI by their EFI partition-sector created. This could also fit my case, and so I could need an EFI boot sector on that USB. Can it be created ?


#6

Well what I know about that is limited… but I think you could use the one that comes with the 64bit anyboot image… if you dd it to a flash drive the flash drive will have a 2MB fat32 EFI partition on it now if I remember correctly… then you could maybe delete and reinstall the Haiku partition really not sure if this would work though?


#7

If you’re using EFi loader shift won’t work. You need to hit space bar to get to the boot menu.


#8

The installation USB has been flashed whit an EFI partition, this is why I can initially boot from there and then select from the loader option the other HAIKU USB installed, ad it works, but I would need that HAIKU usb installed boot itself. If there is no direct solution at the installation option, I’m thinking about copying the EFI partition from the Installation USB to the destination USB (eventually by a Partition manager tool), so that I will install HAIKU targeting the remaining space on the destination USB, This should work…


#9

Yes this is what I suggested I am not certain that it will work though.


#10

Ok, the main problem now is that I do not find a partition manager which handle the HAIKU USB os installed partitions. This is of course due to the unrecognized file system, tried with the PM in Windows 10 and linux Gparted as well, Haiku Disk Drive of course detects them , but does not handle operations of copy-merge-resize . Can you suggest a better way to proceed?
Thanks


#11

you cannot resize BeFS right now


#12

You have to delete, recreate at the right size, then install to it… with the 2MB EFI partition intact… I think, untested YMMV.


#13

yes, it could be a way, I’ll give a try as possible and let know.
Thank you


#14

ok, it has worked!
this is what I’ve done:
-two USB stick 7.2 Gb each, one was the installation media, the other was the installed Haiku
-booted the USB with the installed HAIKU and left it running
-on another pc already booted (Windows 10) I’ve plugged-in the installation media and then formatted the 1.2 Gb partition containing the Haiku live system to trasform that partition in an empty FAT32 by using a partition manager so that the live system has been deleted
-created an empty partition on the 6 Gb remaining space
-left the EFI partition as it was
-unplugged the USB just modified and plugged it on the other pc with the HAIKU installed system running
-runned the installer from there targeting the 6 Gb partition for the installation, preparing it with Be filesystem
-at the end of the installation I’ve shutted down and plugged-in this fresh installed USB stick in the other pc which was shutted down menawhile, ad reboot from there with the selective boot, showing now this USB stick EFI bootable, HAIKU has loaded.
And it was just a clone of the previous system from were I had performed the installation, with the personalization that I recently made (Libreoffice, sound settings, printer, some icon position change…).
Good!


#15

Well… all you would have had to do before is delete the Haiku partition from a freshly imaged USB drive and then create a new 7.2GB-2MB BeFS partition… now you have a wasted 1.2GB fat32 partition right?

Perhaps not wasted though at least you can use that area to exchange files with windows.

At least you know it works now though.


#16

you’re right, that was what I wanted, but noway to resize-move the drive partitions with any partition manager I use. Maybe I haven’t looked for it enough….
Thank you


#17

Don’t resize delete it entirely… then that space will be available when you create your new Haiku partition.