Installation issues on a simple Core2Duo

I had the great idea to give a friend a working Haiku Box after he had complained that he hadn’t managed to do it himself yet. »Nothing easier than that« i thought and now here i am, failing myself - even against a completely unworthy opponent: A crummy Core2Duo, on which Haiku was already running before.

What am i doing wrong? Booting from DVD or USB just works fine, but i can’t boot from the internal drive and i have now gone through all format-, boot- and bios-options. In the best scenario i briefly see the bootloader (if i have prepared two partitions), then immediately »black« without any disc activity.
Also booting from DVD and than »shifting« over to the internal drive does’nt help.

It’s an HP Compaq 8000 SFF with Core2Duo and no fancy stuff.

I have it running on a HP T520 thin client OK, (in MBR mode, efi is more difficult) - did you initialize the disk, & give it a Be filesystem - that was all I had to do to install it on mine.

1 Like

Yes, »of course« i did. Also tried the trick with copying the second boot partition from the DVD but …

Maybe the syslog from an unsuccessful boot that you grab after booting the DVD will show what’s wrong.

1 Like

Tried following the Boot Loader Troubleshooting guide yet?

My usual “go-to”/“top-three” safe-mode options:

  • Use fail-safe graphics driver.
  • Disable SMP
  • Disable ACPI

If any of those works, they can be made “permanent” (see linked guide).

(but do try the other options if needed)

In any case, also useful… the Reporting Bugs guide.

Good luck!

1 Like

Ahoy @stoltenberg ,

I found so chipsets’ capabilities and support in Haiku also cause some quirks in the boot process.
Hardly I could find that this machine has Intel® GMA 4500M chipset, but it had not helped a lot as Besly HW database consists Chipset information only if an integrated on-board graphics in chipset related to it, so there is no column/info of chipsets to compare applicable notices users had written about what is about disabled to be able to boot and not working out-of-the-box after install.

Also there were no enlisted HP Compaq 8000 SFF,
but only a newer model - HP Compaq 8100 SFF - which has a Core i5 processor, so its chipset surely different.

1 Like

Dang that’s an old machine! I would say install Haiku in legacy/BIOS mode without any EFI partitions or files and with an Intel (MBR) partition map with a single, active Haiku (Be File System) partition for the OS (and other partitions below that as needed).

Then, run Installer to copy everything over and under Tools, set up the boot menu. I’ve noticed sometimes Haiku frustratingly doesn’t boot after an install, and manually setting up the boot menu after sometimes helps.

1 Like