Install PHP

Howdy,
I cant seem to find how to install PHP. It is not listed in HaikuDepot. What is the correct method for getting it?
Thanks!

Currently it fails to build on the first try, so it doesn’t get into the prebuilt packages. You need to build it yourself using haikuports.

Thanks. I read through the wiki for haikuports but it seems more geared towards setting up Haikuporter to create recipes. How do I use it to install from haikuports instead?

You need to set up haikuporter and run it to build things from the recipe. There is no “install from haikuports” in this case because the pre-built package is not available and you have to build it yourself, for now. Or just wait until someone figures out this problem in the php configuration script and fixes it :slight_smile:

Thanks.
So I followed the installation instructions here (https://github.com/haikuports/haikuporter). If I issue:
./haikuporter mesa -j4
I then get this error:
haikuporter env python 3 no such file or directory
Thoughts?

Have you python3 installed? If not run: pkgman install cmd:python3.

I tried with haikuport but that didnt work. Using your command did though!
I then had to create a /boot/home/haikuports/packages folder.
Now a different message: Error: The version of the recipe file format used in the ports tree is older than the one supported by the haikuporter. Error: Please upgrade the ports tree.

I guess that means I’m SOL until someone can update the recipe?

Problem can be caused by wrong TREE_PATH in haikuports.conf. See https://github.com/haikuports/haikuports/issues/3462.

So many questions. I appreciate it.
Thanks, that did the trick and it tried to build.
It ended with:
Warning: skipping php-5.6.37, as it is untested on the target architecture.
Error: No version of php can be built

You can use my PHP 7.4.3 recipe: https://github.com/haikuports/haikuports/pull/5127. Patch can be applied by downloading https://patch-diff.githubusercontent.com/raw/haikuports/haikuports/pull/5127.patch and calling git am <path to downloaded patch file>.

How do I tell haikuporter to use that specific recipe?

It should take it automatically if you applied patch. haikuporter --no-source-packages php should work.

Its not my day. I downloaded the patch file and ran it. It mentioned some trailing whitespaces and then
error: corrupt patch at line 201
PAtch failed at 0001 dev-lang/php/patches/php-7.4.3.patchset

I am sharing php_x86-7.4.3-1-x86_gcc2.hpkg now shared on beshare.

I plug my old article “Building packages with haikuporter”.