Install Paladin package on Haiku

I am trying to install Paladin package on Haiku. I downloaded
Paladin and saved it on desktop. Next I opened Terminal and
first ran “cd Desktop” and then ran
"installoptionalpackabe -a Paladin1.3.pkg". The Terminal showed
"To be installed". I do not know whether Paladin has been successfully
installed or not. (I guess it has not since I cannot find it.)

Thanks in advance.

Well, iirc the only thing I did was to write ‘installoptionalpackage paladin’ and it installed and showed up nicely under ‘Applications’. I don’t know why you would ‘cd Desktop’ and I don’t think installoptionalpackage will recognize any version numbers in the name. Use ‘installoptionalpackage -l’ to see a list of all packages available and just refer to those names listed when you want to install anything using ‘installoptionalpackage’.

I used “installoptionalpackage -a paladin”, the terminal showed "to be installed"
and stopped.

On the other hand, I tried “installoptionalpackage -a vim” and the installation
worked smoothly.

installoptionalpackage is a script which works kinda like a simple package manager. It downloads the program/library and installs it for you.

Type installoptionalpackage for list of options.

Awhile back Haiku got a packageinstaller which Paladin uses. Meaning, a program can be made into a package format (.pkg) and you would use /boot/system/apps/packageinstaller to install it. Paladin is the only program I know that uses pkg format on Haiku today. All others use .zip or .7z to package programs or libraries.

Paladin is also offered with installoptionalpackage (in my revision of Haiku) so use that method instead which is easier and faster. Make sure installoptionalpackage offers paladin first because older versions of Haiku offer less packages to install.

What is your version of Haiku?? Mine is R1/Alpha 2, which
I got from

r39915 (nightly image) gcc4 hybrid. Alpha2 is gcc2 hybrid.

Most nightly images stable but sometimes not the case. Alpha2 release is fairly outdated. Lots of changes & fixes since then. Good to try newer image every 3 to 5 months.

gcc2 & gcc4 work pretty much the same. gcc2 better for BeOS programs (less issues) and gcc4 for newer sdl & opengl games. Best to stick with gcc2 hybrid since you’re running from virtual machine. Most of Haiku software is at

Looked and saw Paladin was added 4 months ago to installoptionalpackage in Haiku (in r38574). So, Alpha2 won’t have it.

I tried haiku-nightly-r39915-x86gcc2hybrid-cd. When I typed “installoptionalpackage -l”,
paladin was listed in the output. However when I typed “installoptionalpackage paladin”,
the output was as follows:

To be installed: Paladin Fastdep CCache
Installing …
No data received.
No data received.

The network settings are OK. I can ping anywhere without problems.

I tested little while ago and script installed Paladin for me. Using r39915. Maybe network connection timing out for you? You can try different time and see if it works.


  1. installoptionalpackage -a paladin

installoptionalpackage uses wget to download the files. So, if they still fail, try:

Does wget work or fail in getting the file? Does it timeout? Do you get an error and what is it?

The output is as follows:

–2010-12-28 13:52:48--
Connecting to||:80… connected.
HTTP request sent, awaiting response… No data received.

(Repeated here)

wget is sending a http request but hears nothing back. Either the http request does not reach the destination or the reply does not make it back to you. You need to get a reply back before the download can start.

I think you were running Haiku in a virtual machine. I strongly guess you have some type of DNS issue.

My ping results below (from Windows). Notice the IP address I get for haiku-files (which I confirmed with

Pinging [] with 32 bytes of data:

Reply from bytes=32 time=81ms TTL=46
Reply from bytes=32 time=81ms TTL=46
Reply from bytes=32 time=80ms TTL=46
Reply from bytes=32 time=81ms TTL=46

The IP address you get from wget is The IP address you get is wrong.

Reasons likely is DNS not correctly set (or broken). Check Windows DNS against DNS in your router.

Post your results from pinging:
Do this in Haiku & Windows to see if they match or differ and provide output here.

Edit: the IP you obtain with wget points to University of Kentucky and looks like they may have broken DNS. Try ping first and later can try trace route to see if you can reach (which I strongly think you don’t).

In my host Linux, when I entered ping, the output was as follows:

PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=46 time=118 ms
64 bytes from ( icmp_seq=2 ttl=46 time=91.5 ms
64 bytes from ( icmp_seq=3 ttl=46 time=96.2 ms

However in my guest Haiku, when I entered ping, the output was as follows:

PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=253 time=24.583 ms
64 bytes from icmp_seq=1 ttl=253 time=18.212 ms
64 bytes from icmp_seq=2 ttl=253 time=18.052 ms

I observed that this version of Haiku does not have WebPositive app. However the R1/Alpha 2
version of Haiku has WebPositive app. When I used the R1/Alpha 2 version of Haiku on my VM,
I was able to browse the web pages using WebPositive app. My VM Networking settings are:

Attached to: Bridged Adapter
Name: eth0
Adapter Type: Intel PRO/1000 MT Desktop(82540EM)

Linux is finding the right IP for haiku-files. Haiku is not. Try changing to NAT.

Maybe that’ll fix it? I use Haiku on partition + SDHC card and QEMU (slow) for checking stuff out. Will test one or two things out in QEMU and report back a little later.

Alpha images include extra software compared to the nightly image. This won’t matter with working network connection & proper working of installoptionalpackage. Webpositive is one of the packages that can be installed by the script. That script has a good number of programs and libraries that can be installed but only gets updated with new revisions of Haiku. You get fewer and older packages on older versions of Haiku when using installoptionalpackage.

checked in QEMU. Ping doesn’t work in QEMU but does show 1 line with the IP which is correct for me. Also tested with wget and had the right IP for haiku-files. Installoptionalpackage will work for you once you get the right IP in VirtualBox.

I changed the Networking settings of VM to NAT. It works!
I successfully installed Paladin on Haiku.

Thanks for your kind help.

Sure, no worries Eva. Someone told you to use bridged connection when they should have said NAT. Causing serious network problem which is now fixed.

Now you can enjoy using and testing out Haiku. Next you’ll want to install Webpositive and maybe BeZillaBrowser too. Look at packages from installoptionalpackage and try some of those out first and then download others from and try those.