Install on Lenovo Thinkpad T495. No boot

Hello everyone !
New to Haiku, I was trying a new linux distro when I discovered Haiku !
I’ve tried it on virtualbox yesterday and been very impressed, so I decided to give it a try on real hardware (Lenovo Thinkpad T495 and Chuwi Larkbox Pro)
I would need your help.
I’ve read and try everything I found on documentation, but I’ve never succeeded in booting after install.
Maybe someone would tell me what I did wrong ?

(My T495 Lenovo is :

  • AMD Ryzen Pro 7
  • AMD Radeon Vega Integrated Graphics)

Here is everything :

  1. I first booted on my Gparted USB Live to delete all the partitions, resulting in a raw disk

  2. I prepared the BIOS for booting on Haiku’s USB key (R1/beta3, 64-bit)
    (I must admit it took me a while to find how to make it boot !! Blank screen with multiple failures, Haiku’s logo screen never ending, I had everything and tested a lot before finding how to)
    So here are my settings :
    – disable secure boot
    – disable TSME
    – disable Security Chip
    – UEFI mode, disable CSM support
    – disable OS Optimized Default

  3. suddenly, tadam… I can boot on the USB key !
    But, first observation, I was never asked to Try or Install Haiku
    This is very curious because on another computer (CHUWI larkbox pro), it first asks if you want to try or install, with the same USB key !
    Here, it boots on Live version without asking anything… why ?

  4. From the application menu, I click on Install
    Going to the partition manager, I initialize my disk (Intel…), create a unique partition (Be, active), format the partition (Be).
    Like what is said on documentation. Then I select my new partition as the output of installation (source is USB key) and begin !
    Everything ends ok. I quit the install app, then reboot, get the USB key off… and … nothing.
    I never boot on haiku. Computer stops, asks me to select a source to boot, and never want to boot on the NVMe.

what’s wrong ?

I did the same on VirtualBox, no problem at all.
I tried at least 50 times… making EFI partitions, creating grub-install, nothing is working. It’s not bootable.
I tried to install bootmanager (also not working at all) etc… nothing works.
I can not boot.
I even can not use the USB key to select the boot (with SHIFT), it doesn’t work either.

any idea ?

UEFI booting needs a GPT style partition table. It’s mentioned in the guide.

Thank you very much Lrrr for the link ! :slight_smile:
It helped me a lot.

One thing, I may have done a mistake with the bootloader (or maybe not)
The computer can boot without the USB key now, but internet doesn’t work in that case (the ethernet connection disconnects and reconnects every 15 seconds).
But if I boot on the Haiku’s USB key and then take off the key from the computer when started, no problem.

Here is what I did from the beginning again :

  1. I first booted on my Gparted USB Live to delete all the partitions, resulting in a raw disk

  2. I prepared the BIOS for booting on Haiku’s USB key (R1/beta3, 64-bit)
    Here are the settings :

  • disabled secure boot
  • UEFI mode, disabled CSM support
  • disabled OS Optimized defaults
  1. Booted on Haiku’s USB key,
  • Install process : first, set partitions.
    Initialized the raw disk (GUID partition table),
    created a first partition (EFI) of 64MB named EFIBOOT, formated it (FAT32).
    created a second partition (Be FS), named Haiku, formated it (Be FS)
  • Installed Haiku from the key to the Haiku’s partition created.
    Once finished, mounted EFIBOOT partition,
    Then opened a terminal and wrote :

mkdir -p /efiboot/EFI/BOOT
mv /Haiku/system/data/platform_loaders/haiku_loader.efi /efiboot/EFI/BOOT/BOOTX64.EFI

  1. From that, the computer could boot without the Haiku’s USB key… But internet doesn’t work if I do not use the key to boot.

Do you know why ?

Haiku isn’t perfect, it’s probably a bug. See ReportingBugs – Haiku for reporting issues.

Yes, there are a few problems, but it’s a great project. I’m quite impressed.

Be that as it may, thank you for your help.
I’m going to explore more.