Install Alpha2 from Alpha1?

I downloaded the anyboot image. Is there anyway I can install Alpha2 using the image? My Alpha1 installation doesn’t “see” my 8Gb blank FAT format thumb drive, then it turns the thumb drive off.

I tried using linux to make a usb anyboot image. When I boot from it the Haiku boot screen appears, then the usb drive turns off. I know this because there is a light(led) that goes off when the 5 volts is removed from pin 1 of the internal usb connector, similar to what happens when it is “safely removed” by the operating system. The kernel then panics because it can’t mount the boot image. I guess I’ll try burning a cd.

I’ve downloaded the Alpha2 iso image and I can mount it. Is there a way I can install Alpha2 to another partition from it without actually burning it to a cd. The installer doesn’t offer it as a choice to install from, though it shows up in the partition list.

I haven’t tried using R1A1’s Installer to install new nightlies or R1A2, but there have been some changes to Installer’s code since then.

What you could try, is mounting a raw image (or extracting the raw image from the anyboot see: luroh’s comment ), then running <mounted image>/system/apps/Installer

As for Installer not seeing a mounted ISO image, IIRC Xeon3D reported a recent ticket for it.

Thanks mmadia. I was able to download an image file from one of the mirrors and install Alpha2 with the Alpha1 installer. I had also tried QEMI and was able to run the anyboot image, but couldn’t mount other partitions for installation.