If Haiku Beta 3 64bit cannot play DVD... Audio CD performance is very poor in MediaPlayer

I cannot play DVDs (Region 2) with MediaPlayer, VLC, and SMplayer…
No idea why, Haiku was playing DVD in the past even it took some time then to load the DVD with VLC.

Please can you all confirm and test the DVD and Audio performance on the Drive (not files)?

The mount path has to be set each time you use VLC:

It is not!: /dev/dvd

Can you play audio CDs the old way - play the virtual WAV files exposed by the cdda_fs in Media Player?

To find the correct device mount path use the DriveSetup app:

or the df command in Terminal:

Then insert the correct Device mount path in VLC:

VLC will not find the DVD path automatically nor store it in preferences!

In SMPlayer you have to insert the mount path in CD an DVD preference field:

Then the DVD’s will play!

Edit: If the DVD plays in VLC you can then drag n’ drop the DVD icon to the VLC player to play it! No need to insert the mount device point each time for the DVD.


I just tried but it is a very poor performance!

If I copy the .wav files MediaPlayer will play them just fine!

How to runn the files in Terminal?

1 Like

I experience exactly the same issue with direct play performance vs copied .wavs!

Probably this is a bug in cddafs and should be fixed. Please do open a ticket if there is not one already.