IDE Haiku -> SATA HD doesn't boot

I am able to boot (quite quickly and it works great) Haiku in my son’s old computer (AMD Athlon 64 Sempron 3200+) and thought I’d try to install it on a SATA drive and try to boot it from that.

After repartitioning the drive in Vista (can’t format it, as NTFS is the only option), I then brought it over to the AMD system and Initialized the disk as a BFS partition. Then I ran the Installer. It copied everything VERY fast.

Then I ran Bootman from the Terminal. It installed the boot menu seemingly fine. I rebooted and the menu came up (“Haiku” being the only choice, naturally) and started to boot…

But all I ever get is “Booting Haiku…” and a blinking cursor beneath it. Nothing more ever happens.

I then thought maybe it was because I never selected the drive/partition as Active. So I put it back on the other system, and went into Vista and “Activated” (HA!) the drive. Tried running it on that system… same message.

Tried running it on the AMD system… same message.

Am I doing something wrong?

I will say, however, that Haiku sees the partition as FAT16, not FAT32, when I try to Initialize it. Is this a problem? Does Haiku’s DriveSetup have an option for selecting what type of partition is created or what it should be Intialized as? Is there another tool in Haiku I can use, that will work?

Hope someone can help…

On the AMD system, try removing the drive that was there to start with, then re-install the boot menu. Also use DriveSetup to make the BeOS partition on your SATA the active one.

If you were to leave the original drive in, I think that your boot menu would be installed on it and not on your SATA drive.

Also, what are you using for SATA host bus adapters in each system? SATA adapters need device drivers, which I think have to be statically-linked into the kernel to use as boot devices.

Possibly you were able to install on the AMD system because there was a SATA device driver, but not statically linked - it would have been a kernel add-on. SATA didn’t exist yet when the last rev of BeOS shipped.

I would suggest either installing to a parallel IDE drive, or maybe there is some way you can boot off a floppy or USB stick and then mount your SATA drive as the root filesystem.

He is talking about Haiku, which has SATA support, and not BeOS.
I don’t know if Haiku’s bootman is finished. It doesn’t really look like a SATA problem, but problems to find a bootable Haiku. You might need to do a makebootable on the partition.