Icecast anyone?

A typical project for a lazy sunday afternoon: I wanted to pull Icecast from the Haiku depot,
but i just fail at the beginning. After starting via Terminal:
ERROR: You should not run icecast2 as root
The clou is that Haiku is not a multi-user system and can only run applications as root, right?
I tried everything possible in the configuration file and of course the official documentation
does not deal with such a special question.
Any idea (or tips for alternative applications)?

Please do report bugs in 3rd party programs at the haikuports issue tracker, not here.
Here you go:

User is effective root on Haiku (user id is 0, which is root on other systems, the code probably checks for it, and does not allow to run as root. No config file change will help, the check should be ifndef-ed out and recompiled.

1 Like

I’m not sure if it is a bug? I initially suspected the mistake by myself.
but I’ll try my luck there…

It is not abug, but a porting mistake. We port frequently programs what we dont use and can’t test them deeply. So sometimes ports lands in depot which shows problems like this. I assume it is a 2 min fix. @Begasus, afaik you worked on it, if you have nothing against it, i’ll fix it morning afternoon.

Good to know. Then I will be happy to report some more candidates in the future …

Thanks for the report, I’ll try to have a look at it later :slight_smile:

1 Like

Should be fixed, could you update and check again?

Thanks a lot! We have made a step forward.
The bad news: I digged out new problems :wink:

[2019-12-23  19:01:30] WARN fserve/fserve_recheck_mime_types Cannot open mime types file /etc/mime.types
FATAL: could not open error logging (/packages/icecast-2.4.4-2/.self/var/log/icecast/error.log): No such file or directory
FATAL: could not open access logging (/packages/icecast-2.4.4-2/.self/var/log/icecast/access.log): No such file or directory
FATAL: Could not start logging

Thanks for reporting (again) :slight_smile: I’ll look into it when I get around to it

1 Like

Hey Haikuports people, please use the “untested” recipe marker when you do this! Your work otherwise lands directly in HaikuDepot, and checking that a recipe merely builds is not enough to put it in the hands of poor unsuspecting users.



Try to create a folder /var/log/icecast and try again?

BTW, via Terminal you can use the Unix/Linux way to create a new user

  • useradd mynewuser [options] (give it a user id and group id ≥1000 to avoid some problems)
  • passwd mynewuser
  • su mynewuser or su - mynewuser to use this new user account

Now start your application

  • /path/to/executable (drag+drop works)

I absolutely don’t know if this works. Would be nice to know.

1 Like

Sorry for the delay. Now it is working like a charm!
After changing the path for the log files there are no errors left.
Thank you!

1 Like

Thank you for the interesting hints. I will test the commands tomorrow.
(sitting on a mac right now :wink: )

Thanks for reporting! :slight_smile: